KMP POJ3080 暴力KMP

6 篇文章 0 订阅

POJ3080

Blue Jeans

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20993 Accepted: 9294

Description

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. 

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers. 

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC. 

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:

  • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
  • m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

Sample Input

3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output

no significant commonalities
AGATAC
CATCATCAT

 

题目大意:给m个长度为60的基因串,找最长公共子序列,在最长的情况下要满足字典序最小。

暴力真难想,暴力真是最难想的嘤嘤嘤:十分暴力地取出第一个字符串中的各个长度各位为起点的字符串(子序列),去匹配其他字符串,成功则更新,不成功继续遍历,每次记录最长的,字典序最小的。

注:1)如果某一子序列,在某一60长基因串中找不到,那么可以直接跳出遍历下一子序列

       2)如果某一长度的子序列没有任何一个能匹配成功,可以直接结束暴力

 

#include <cstdio>
#include <cstring>

const int maxm=11;
const int maxc=66;

int m;
char dna[maxm][maxc],p[maxc],tem[maxc];
int Next[maxc];
int flag;

void get_Next(char* s,int* Next)
{
	int m=strlen(s);
	Next[0]=Next[1]=0;
	for(int i=1;i<m;++i){
		int j=Next[i];
		while(j&&s[i]!=s[j]) j=Next[j];
		if(s[i]==s[j]) Next[i+1]=j+1;
		else Next[i+1]=0;
	}
}

void Find(char* ss,char* s,int* Next)
{
	int j=0,n=strlen(ss),m=strlen(s);
	for(int i=0;i<60;++i){
		while(j&&s[j]!=ss[i]) j=Next[j];
		if(s[j]==ss[i]) ++j;
		if(j==m){
			return;
		}
	}
	flag=0;
}

int main()
{
	int t,stop;

	scanf("%d",&t);
	while(t--){
		strcpy(tem,"\0");
		scanf("%d",&m);
		for(int i=0;i<m;++i)
			scanf("%s",dna[i]);
		for(int l=1;l<=60;++l){
			stop=0;
			for(int i=0;i<60-l+1;++i){
				flag=1;
				for(int j=0;j<l;++j){
					p[j]=dna[0][i+j];
				}
				p[l]='\0';
				get_Next(p,Next);
				for(int j=1;j<m;++j){
					Find(dna[j],p,Next);
					if(!flag) break;
					stop=1;
				}
				if(flag&&(strlen(tem)<strlen(p)||strcmp(p,tem)<0))
					strcpy(tem,p);
			}
			if(!stop) break;
		}
		int c=strlen(tem);
		if(c>=3)
			printf("%s\n",tem);
		else
			printf("no significant commonalities\n");
	}

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
KMP算法和暴力匹配算法是两种字符串匹配算法,它们的主要区别在于匹配失败时的处理方式和求解next数组的方法。 1. 暴力匹配算法: 暴力匹配算法,也称为朴素匹配算法,是一种简单直接的字符串匹配方法。它的思想是从主串的第一个字符开始,逐个与模式串进行比较,如果匹配失败,则将主串的指针后移一位,再次与模式串进行比较,直到找到匹配或者主串遍历完毕。 2. KMP算法: KMP算法是一种改进的字符串匹配算法,它通过预处理模式串,构建一个next数组,来实现在匹配失败时跳过一部分字符,从而提高匹配效率。KMP算法的核心思想是利用已经匹配过的信息,避免不必要的比较。 KMP算法的求解next数组的方法是通过模式串自身的特性来确定。具体步骤如下: - 首先,初始化next数组,next = -1,next = 0。 - 然后,从模式串的第二个字符开始,依次计算next[i]的值。 - 对于next[i]的计算,如果模式串的第i个字符与前面的字符匹配成功,next[i] = next[i-1] + 1;如果匹配失败,则需要根据已经匹配的信息来调整next[i]的值,具体调整方法是找到模式串的一个前缀子串,使得该前缀子串的后缀子串与模式串的前缀子串匹配,且长度最长。即next[i] = next[next[i-1]]。 在KMP算法中,当匹配失败时,根据next数组的值,可以直接将模式串的指针后移next[j]个位置,而不需要回溯到主串的前面重新开始匹配,从而提高了匹配效率。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值