RMQ POJ3264

1 篇文章 0 订阅

RMQ

RMQ(Regional Maximize/Minmize Query)区间最值问题

一般的处理方法是ST表,即对于序列A的每个位置i处理出一个数组dp[i][j] 表示 [i……i+(2^j)-1]这个区间的最值(也就是i往后走2^j步)(倍增思想)

最小区间[i,i],显然dp[i][0] = a[i];

继续往上推,dp[i][j]可以拆分为两个更小的部分dp[i][j-1]dp[i+(2^(j-1))][j-1]……

 

RMQ

void RMQ()
{
    for(int j=1;j<=30;++j){
        for(int i=1;i<=n;++i){
            if(i+(1<<j)-1<=n){
                ma[i][j]=max(ma[i][j-1],ma[i+(1<<(j-1))][j-1]);
                mi[i][j]=min(mi[i][j-1],mi[i+(1<<(j-1))][j-1]);
            }//状态转移m[i][j]表示从i开始2^j个数中的最值
        }//m[i][j]即为m[i][j-1]与m[i+(1<<j)][j-1]中的最值
    }//如同二分,(1<<(j-1))为[j-1]所能包括的元素个数(长度)
}//而且必须j在外,根据状态转移,总是从低j向高j转移的,需要先算出小的j的才能推出大的j的

 

最大最小值询问

一段区间可以被两段2^k长度覆盖(可能有重合),所以就可以轻松地询问最大最小值辣

int qmax(int l,int r)
{
    int k=(int)(log(r-l+1.0)/log(2.0));
    return max(ma[l][k],ma[r-(1<<k)+1][k]);     //可能会有重叠部分,但这两部分会完全覆盖
}
//合在一起会快一倍
int qmin(int l,int r)
{
    int k=(int)(log(r-l+1.0)/log(2.0));
    return min(mi[l][k],mi[r-(1<<k)+1][k]);
}

 

POJ3264

Balanced Lineup

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 64360 Accepted: 30000
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

 

直接上代码辣

#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;

const int maxn=50020;

int n,q;
int ma[maxn<<1][30];
int mi[maxn<<1][30];

void RMQ()
{
    for(int j=1;j<=30;++j){
        for(int i=1;i<=n;++i){
            if(i+(1<<j)-1<=n){
                ma[i][j]=max(ma[i][j-1],ma[i+(1<<(j-1))][j-1]);
                mi[i][j]=min(mi[i][j-1],mi[i+(1<<(j-1))][j-1]);
            }//状态转移m[i][j]表示从i开始2^j个数中的最值
        }//m[i][j]即为m[i][j-1]与m[i+(1<<j)][j-1]中的最值
    }//如同二分,(1<<(j-1))为[j-1]所能包括的元素个数(长度)
}//而且必须j在外,根据状态转移,总是从低j向高j转移的,需要先算出小的j的才能推出大的j的

int qmax(int l,int r)
{
    int k=(int)(log(r-l+1.0)/log(2.0));
    return max(ma[l][k],ma[r-(1<<k)+1][k]);     //可能会有重叠部分,但这两部分会完全覆盖
}
//合在一起会快一倍
int qmin(int l,int r)
{
    int k=(int)(log(r-l+1.0)/log(2.0));
    return min(mi[l][k],mi[r-(1<<k)+1][k]);
}

int main()
{
    int h;
    int l,r;

    while(~scanf("%d%d",&n,&q)){
        for(int i=1;i<=n;++i){
            scanf("%d",&h);
            mi[i][0]=ma[i][0]=h;
        }
        RMQ();
        while(q--){
            scanf("%d%d",&l,&r);
            printf("%d\n",qmax(l,r)-qmin(l,r));
        }
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值