1141: 松哥的困惑VII (water)

题目

在这里插入图片描述

Sample Input

24

Sample Output

3 3

思想

这道题就是把数据拆分为2的幂数与剩下的那个数···直接跑循环累加就完事了。

AC代码

#include<bits/stdc++.h>
using namespace std;
#define rep(i,a,b) for(int i=a;i<=b;++i)
#define pre(i,a,b) for(int i=a;i>=b;--i)
#define m(x) memset(x,0,sizeof x)
#define IOS ios::sync_with_stdio(0); cin.tie(0); cout.tie(0);
#define PI acos(-1)
typedef long long ll;
const int INF =  0x3f3f3f3f;
const int mod = 1e9+7;
const int maxn = 1e5+10;
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int cnt = 0;
        while(1)
        {
           if(n%2==0)
           {
               cnt++;
               n/=2;
           }else{
               break;
           }
        }
        printf("%d %d\n",n,cnt);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值