分组背包

5 篇文章 0 订阅

开始整理dp中的背包问题,可以说题型都很基础,但是细节需要注意!

分组背包 基础
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
 

Output

For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
 

Sample Input

     
     
2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0
 

Sample Output

     
     
3 4 6
 
 

对于分组背包:

     ①题的基本类型: 有N件物品和一个容量为V的背包。第i件物品的费用是c[i],价值是w[i]。这些物品被划分为若干组,每组中的物品互相冲突,
     最多选一件。求解将哪些物品装入背包可使这些物品的费用总和不超过背包容量,且价值总和最大。
 ②题解: 第一步:确定状态
  f[k][v]表示前k组物品花费费用v能取得的最大权值
第二步:确定状态转移方程
f[k][v]=max{f[k-1][v],f[k-1][v-c[i]]+w[i]|物品i属于组k}
使用一维数组的伪代码如下:
for 所有的组k
       for v=V..0
         for 所有的i属于组k
            f[v]=max{f[v],f[v-c[i]]+w[i]}
“for v=V..0”这一层循环必须在“for 所有的i属于组k”之外。这样才能保证每一组内的物品最多只有一个会被添加到背包中。

dp.背包问题.分组背包

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>

using namespace std;

int n,m;
int A[105][105],dp[105];

void solve()
{
	for(int i=0;i<n;i++)
		for(int j=1;j<=m;j++)
		scanf("%d",&A[i][j]);
	memset(dp,0,sizeof(dp));

			for (int x = 0; x < n; x++)
    {
        for (int i = m; i >= 0; i--)
            for (int j = 1; j <= m; j++)
                if (i >= j)
                    dp[i]=max(dp[i], dp[i - j] + A[x][j]);
    }
    printf("%d\n", dp[m]);

}


int main()
{
   while(~scanf("%d%d",&n,&m)&&n&&m)
	solve();
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值