贪心6 HDU - 1800

在一个遥远的未来,PPF帝国为了扩张领土,决定攻击火星。然而,如何将士兵送往火星成为一个难题。最终,通过购买魔法扫帚来解决交通问题。本篇介绍了一个算法,旨在通过分析士兵的能力等级来确定最小数量的魔法扫帚,以便进行有效的飞行训练。
摘要由CSDN通过智能技术生成

Description
In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the broomstick needed .
For example :
There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;
One method :
C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.
D could teach E;So D E are eligible to study on the same broomstick;
Using this method , we need 2 broomsticks.
Another method:
D could teach A; So A D are eligible to study on the same broomstick.
C could teach B; So B C are eligible to study on the same broomstick.
E with no teacher or student are eligible to study on one broomstick.
Using the method ,we need 3 broomsticks.
……

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed.
Input
Input file contains multiple test cases.
In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)
Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);
Output
For each case, output the minimum number of broomsticks on a single line.
Sample Input
4
10
20
30
04
5
2
3
4
3
4
Sample Output
1
2
题目概要
在输入的第一行给出士兵的个数n,接下来的1~n行给出每个士兵的等级。
等级高的士兵可以教等级低的士兵学魔法扫帚,以此类推构成一个序列,每个序列有一把扫帚。
求出所需最少的扫帚数。
贪心准则
取同一等级士兵人数的最大值。
代码

#include<iostream>
#include<cstdio>
#include<map>
using namespace std;
int main(){
    int T;
    while(scanf("%d",&T)==1){
        map<int,int>mp;
        int max=1;
        while(T--){
            int level;
            scanf("%d",&level);
            map<int,int>::iterator it=mp.find(level);
            if(it!=mp.end()){
                it->second=it->second+1;
                if(it->second>max)max=it->second;
            }
            else mp.insert(pair<int,int>(level,1));
        }
        cout<<max<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值