Wireless Network POJ - 2236

Wireless Network POJ - 2236

##
An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. “O p” (1 <= p <= N), which means repairing computer p.
2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.
Output
For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL

题解:这道题是并查集的简单拓展,只需要预先得出各点之间的距离关系,之后利用并查集算出即可;

#include<cstdio>
#include<cstring>
using namespace std;

int n,d;
const int maxn=1005;
struct node{
    int x;
    int y;
}m[maxn];                           //定义结构体存放位置坐标。
int a[maxn][maxn];                  //用来把i,j的距离小于d的标记。
int vis[maxn];                      //用来标记电脑是否已修复。
int par[maxn];                     //并查集,父节点;

void ju(){
    memset(a,0,sizeof(a));
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;i++){
        for(int j=1;j<=n;j++){
            if((m[i].x-m[j].x)*(m[i].x-m[j].x)+(m[i].y-m[j].y)*(m[i].y-m[j].y)<=d*d){
                a[i][j]=1;
            }   //如果两者之间距离小于d,则标记两点,即啊a【i】【j】=1;
        }
    }
}
void init(int x){
    for(int i=1;i<=x;i++)
        par[i]=i;
}
int find(int x){
    if(par[x]==x){
        return x;
    }else{
        return par[x]=find(par[x]);
    }
}

//合并x,y所在的集合;
void unite(int x,int y){
    x=find(x);
    y=find(y);
    if(x==y) return ;
    par[x]=y;

}
int main()
{
    scanf("%d%d",&n,&d);
    for(int i=1;i<=n;i++){
        scanf("%d%d",&m[i].x,&m[i].y);
    }
    ju();         //判定哪些位置之间的距离小于d;
    init(n);      //将每台电脑的父节点设为自己,即初始化每台电脑互相独立;

    char p[5];
    int b,c,d;
    while(scanf("%s",p)!=EOF){
        if(p[0]=='O'){
            scanf("%d",&b);
            vis[b]=1;      //表示此台电脑已经修复;
            for(int i=1;i<=n;i++){
                if(a[b][i]==1&&vis[i]==1){
                    unite(b,i);
                }   //查找之前已修复过的电脑与此台电脑之间的距离是否有小于d的,若小于d则将二者放到一个集合中;
            }
        }else{
            scanf("%d%d",&c,&d);

            //查询c,d是否在统一集合;
            if(find(c)==find(d)){
                printf("SUCCESS\n");
            }else{
                printf("FAIL\n");
            }
        }

    }



    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值