poj3061,求连续数字中达到给定数字最短数字 贪心

Subsequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8030 Accepted: 3092

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

Source



Subsequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8030 Accepted: 3092
Description


A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input


The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output


For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input


2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
Sample Output
2
3
Source
思路:
先求出第一个连续的数字之和大于s,用一个数记录数字的长度,在从第一个开始减,同时记录连续数字的长度,若是减的数字小于s了,则在原来到达的数字后继续加。。
#include <iostream>

using namespace std;
long long  a[100000+10],b[100000+10];

int main()
{
   int m,i,j,n,s,min,sum,c,l;
   cin>>m;
   while(m--)
   {
      cin>>n>>s;
      for(i=0;i<n;i++)
        {
           cin>>a[i];
           b[i]=a[i];
        }

      for(i=0,j=0,min=1000000,sum=0,l=0;i<n;i++)
      {
         sum+=a[i];
         l++;
         while(sum>=s)
         {
            sum-=b[j++];
            l--;
            if(sum<s)
            {
               if(l<min)min=l+1;
               continue;
            }

         }



      }
      if(min==1000000)cout<<0<<endl;
      else cout<<min<<endl;
   }





    return 0;
}
2014-04-18



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值