UVA 201

UVA 201
Squares

A children's board game consists of a square array of dots that contains lines connecting some of the pairs of adjacent dots. One part of the game requires that the players count the number of squares of certain sizes that are formed by these lines. For example, in the figure shown below, there are 3 squares-2 of size 1 and 1 of size 2. (The ``size" of a square is the number of lines segments required to form a side.)

 

Your problem is to write a program that automates the process of counting all the possible squares.

 

Input

The input file represents a series of game boards. Each board consists of a description of a square array of n2 dots (where 2 <= n <= 9) and some interconnecting horizontal and vertical lines. A record for a single board with n2 dots and m interconnecting lines is formatted as follows:

 

 Line 1: 	n the number of dots in a single row or column of the array

Line 2: m the number of interconnecting lines

Each of the next m lines are of one of two types:

H i j indicates a horizontal line in row i which connects

the dot in column j to the one to its right in column j + 1

or

V i j indicates a vertical line in column i which connects

the dot in row j to the one below in row j + 1

Information for each line begins in column 1. The end of input is indicated by end-of-file. The first record of the sample input below represents the board of the square above.

 

Output

For each record, label the corresponding output with ``Problem #1", ``Problem #2", and so forth. Output for a record consists of the number of squares of each size on the board, from the smallest to the largest. lf no squares of any size exist, your program should print an appropriate message indicating so. Separate output for successive input records by a line of asterisks between two blank lines, like in the sample below.

 

Sample Input

 

4
16
H 1 1
H 1 3
H 2 1
H 2 2
H 2 3
H 3 2
H 4 2
H 4 3
V 1 1
V 2 1
V 2 2
V 2 3
V 3 2
V 4 1
V 4 2
V 4 3
2
3
H 1 1
H 2 1
V 2 1

 

Sample Output

 

Problem #1

2 square (s) of size 1
1 square (s) of size 2

**********************************

Problem #2

No completed squares can be found.

题意:给你一个由点组成的网格,再给一些连结相邻点的操作(横向、纵向),统计里面的正方形。

AC代码:

#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;

int main()
{
    int count=0;
    int n,m,a[15][15],x,y,b[15];
    char t;
    while(cin>>n>>m)
    {
        int ok=0;
        if(count!=0)
            cout<<endl<<"**********************************"<<endl<<endl;
        count++;
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for(int i=0;i<m;i++)
        {
            cin>>t>>x>>y;
            if(t=='V')
            {
                a[y][x]+=1;
                a[y][x-1]+=4;
            }
            else
            {
                a[x][y]+=2;
                a[x-1][y]+=8;
            }
        }//输入并画墙;
        for(int i=1;i<=n;i++)//方块大小
        {
            for(int j=1;j<=n-i;j++)//方块位置
            {
                for(int k=1;k<=n-i;k++)//方块位置
                {
                    int sum=0;
                    for(int p=j;p<=j+i-1;p++)//小方块
                    {
                        for(int o=k;o<=k+i-1;o++)//小方块
                        {
                            if(p==j&&a[p][o]&2) sum++;//左边墙
                            if(o==k&&a[p][o]&1) sum++;//上边墙
                            if(p==j+i-1&&a[p][o]&8) sum++;//右边墙
                            if(o==k+i-1&&a[p][o]&4) sum++;//下边墙
                        }
                    }
                    if(sum==4*i)
                    {
                        b[i]++;
                        ok=1;
                    }
                }
            }
        }
        cout<<"Problem #"<<count<<endl<<endl;
        if(ok==0)
            cout<<"No completed squares can be found."<<endl;
        else
        {
            for(int i=1;i<=n;i++)
            {
                if(b[i]!=0)
                    cout<<b[i]<<" square (s) of size "<<i<<endl;
            }
        }

    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值