ACdream 1195 判断数独棋盘是否合法

ACdream1195

Sudoku Checker

Time Limit: 2000/1000MS (Java/Others)  Memory Limit: 128000/64000KB (Java/Others)
Problem Description

Sudoku is a popular single player game. The objective is to fill a 9x9 matrix with digits so that each column, each row, and all 9 non-overlapping 3x3 sub-matrices contain all of the digits from 1 through 9. Each 9x9 matrix is partially completed at the start of game play and typically has a unique solution.

      

Given a completed N2×N2 Sudoku matrix, your task is to determine whether it is a valid solution.

A valid solution must satisfy the following criteria:

  • Each row contains each number from 1 to N2, once each.
  • Each column contains each number from 1 to N2, once each.
  • Divide the N2×N2 matrix into N2 non-overlapping N×N sub-matrices. Each sub-matrix contains each number from 1 to N2, once each.

You don't need to worry about the uniqueness of the problem. Just check if the given matrix is a valid solution.

Input

The first line of the input gives the number of test cases, T(1 ≤ T ≤ 100).

T test cases follow. Each test case starts with an integer N(3 ≤ N ≤ 6).

The next N2 lines describe a completed Sudoku solution, with each line contains exactly N2 integers.

All input integers are positive and less than 1000.

Output

For each test case, output one line containing "Case #x: y", where x is the case number (starting from 1) and y is "Yes" (quotes for clarity only) if it is a valid solution, or "No" (quotes for clarity only) if it is invalid.

Sample Input
3
3
5 3 4 6 7 8 9 1 2
6 7 2 1 9 5 3 4 8
1 9 8 3 4 2 5 6 7
8 5 9 7 6 1 4 2 3
4 2 6 8 5 3 7 9 1
7 1 3 9 2 4 8 5 6
9 6 1 5 3 7 2 8 4
2 8 7 4 1 9 6 3 5
3 4 5 2 8 6 1 7 9
3
1 2 3 4 5 6 7 8 9
1 2 3 4 5 6 7 8 9
1 2 3 4 5 6 7 8 9
1 2 3 4 5 6 7 8 9
1 2 3 4 5 6 7 8 9
1 2 3 4 5 6 7 8 9
1 2 3 4 5 6 7 8 9
1 2 3 4 5 6 7 8 9
1 2 3 4 5 6 7 8 9
3
5 3 4 6 7 8 9 1 2
6 7 2 1 9 5 3 4 8
1 9 8 3 4 2 5 6 7
8 5 9 7 6 1 4 2 3
4 2 6 8 999 3 7 9 1
7 1 3 9 2 4 8 5 6
9 6 1 5 3 7 2 8 4
2 8 7 4 1 9 6 3 5
3 4 5 2 8 6 1 7 9
Sample Output
Case #1: Yes
Case #2: No
Case #3: No
Source
codejam
Manager


暴力查找就行

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>

using namespace std;
int n;
int a[40][40];
bool checkl(int x){
    bool temp[1005];
    memset(temp,0,sizeof(temp));
    for(int i=0;i<n*n;i++)
        if(!temp[a[x][i]]) temp[a[x][i]]=1;
        else return 0;
    if(*min_element(temp+1,temp+n*n+1)==0)
        return 0;
    else
        return 1;
}
bool checkc(int x){
    bool temp[1005];
    memset(temp,0,sizeof(temp));
    for(int i=0;i<n*n;i++)
        if(!temp[a[i][x]]) temp[a[i][x]]=1;
        else return 0;
    if(*min_element(temp+1,temp+n*n+1)==0)
        return 0;
    else
        return 1;
}
bool checkm(int x,int y){
    int b[40]={0};
    int k=-1;
    for(int i=0;i<n;i++)
        for(int j=0;j<n;j++)
        b[++k]=a[i+x][j+y];
    sort(b,b+k+1);
    for(int i=0;i<k;i++)
        if(i+1!=b[i]) return 0;
    return 1;
}
int main()
{
    int t;
    cin>>t;
    for(int p=1;p<=t;p++){
        cin>>n;
        bool ans=1;
        for(int i=0;i<n*n;i++)
            for(int j=0;j<n*n;j++)
                scanf("%d",&a[i][j]);
        for(int i=0;i<n*n;i++)
            ans=checkl(i);
        //cout<<ans<<endl;
        for(int i=0;i<n*n&&ans;i++)
            ans=checkc(i);
        //cout<<ans<<endl;
        for(int i=0;i<n*n&&ans;i+=n){
            for(int j=0;j<n*n&&ans;j+=n){
                ans=checkm(i,j);
            }
        }
        cout<<"Case #"<<p<<": ";
        if(ans)
            cout<<"Yes"<<endl;
        else
            cout<<"No"<<endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值