ACdream 1412 DP

2-3 Trees

Time Limit: 6000/3000MS (Java/Others)  Memory Limit: 128000/64000KB (Java/Others)
Problem Description

      2-3 tree is an elegant data structure invented by John Hopcroft. It is designed to implement the same functionality as the binary search tree. 2-3 tree is an ordered rooted tree with the following properties:

  • the root and each internal vertex have either 2 or 3 children;
  • the distance from the root to any leaf of the tree is the same.

      The only exception is the tree that contains exactly one vertex — in this case the root of the tree is the only vertex, and it is simultaneously a leaf, i.e. has no children. The main idea of the described properties is that the tree with l leaves has the height O(log l).
      Given the number of leaves l there can be several valid 2-3 trees that have l leaves. For example, the picture below shows the two possible 2-3 trees with exactly 6 leaves.


      Given l find the number of different 2-3 trees that have l leaves. Since this number can be quite large, output it modulo r.

Input
      Input file contains two integer numbers: l and r (1 ≤ l ≤ 5 000, 1 ≤ r ≤ 10 9).
Output
      Output one number — the number of different 2-3 trees with exactly l leaves modulo r.
Sample Input
6 1000000000
7 1000000000
Sample Output
2
3
Source
Andrew Stankevich Contest 21
Manager
和树没关系,就是求组合种类,dp水题
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <map>
#include <cstdlib>
#include <sstream>
#include <queue>
#include <cmath>
using namespace std;
int  c[2510][2510];
int main()
{

    long long n,m;
    while(cin>>n>>m){
        memset(c,0,sizeof(c));
        c[0][0]=1;
        c[1][1]=c[1][0]=1;
        for(int i=2;i<=n/2;i++){
            c[i][0]=1;
            for(int j=1;j<=i;j++)
            c[i][j]=(c[i-1][j]%m+c[i-1][j-1]%m)%m;
        }
        long long dp[15010];
        memset(dp,0,sizeof(dp));
        dp[1]=1;
        for(int i=1;i<n/2+1;i++)
        {
            for(int j=0;j<=i;j++)
            {
                int q=j*3+(i-j)*2;
                dp[q]=(dp[q]+(dp[i]*c[i][j]))%m;
            }
        }
        cout<<dp[n]<<endl;
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值