poj 2352 && hdu 1541 Stars 线段树

题意:

按序在图上插入点,求每次插入点左下方有几个点,点的个数即为此点的等级。输出每个等级点的个数。

思路:

由于插入点的顺序是先下后上的

故可以x轴为准,先查询点的左边有几个点,再插入点,不用考虑y轴。

代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
#define ls rt<<1,l,mid
#define rs rt<<1|1,mid+1,r
const int MAXN=40000;
int st,en;
int tree[MAXN*3];
void push_up(int rt){
    tree[rt]=tree[rt<<1]+tree[rt<<1|1];
    return ;
}
void update(int rt,int l,int r){
    if(l==r){
        tree[rt]=1;
        return ;
    }
    int mid=(l+r)>>1;
    if(en<=mid)
        update(ls);
    if(mid<en)
        update(rs);
    push_up(rt);
}
int query(int rt,int l,int r){
    if(st<=l&&r<=en)
        return tree[rt];
    int ans=0;
    int mid=(l+r)>>1;
    if(st<=mid)
        ans+=query(ls);
    if(mid<en)
        ans+=query(rs);
    return ans;
}
typedef struct Node{
    int x;
    int y;
    int id;
    bool operator <(const Node& a)const{
        if(a.x==x)
            return a.y>y;
        return a.x>x;
    }
}Node;
int main()
{
    int n;
    while(cin>>n){
        memset(tree,0,sizeof(tree));
        Node a[MAXN];
        int ans[MAXN]={0};
        //int m=0;
        for(int i=0;i<n;i++){
            scanf("%d %d",&a[i].x,&a[i].y);
            a[i].id=i+1;
            //m=max(m,a[i]);
        }
        sort(a,a+n);
        for(int i=0;i<n;i++){
            st=1;en=a[i].id;
            ans[query(1,1,n)]++;
            update(1,1,n);
        }
        for(int i=0;i<n;i++)
            printf("%d\n",ans[i]);
    }
    return 0;
}

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值