【二分匹配】HDU 1068

Girls and Boys

Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:
the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
Sample Input
 
 
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
Sample Output
 
 
5 2

题意:首先给出总人数,下列有男有女,把每一个人可以配的人编号列在后面,比如第一个总共有(3)个分别是4 5 6。最后求配完总共有多少对,一个的单个算一对。

由于有重复,所以最后算出最大匹配要除以2得出配对数。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,m,sum;
int last[1002];
bool map[1002][1002],vis[1002];

bool find(int I)
{
    int j,i;
    for(j=0; j<n; j++)
        if(!vis[j]&&map[I][j])
        {
            vis[j]=1;
            i=last[j];
            last[j]=I;
            if(i==-1||find(i))
                return 1;
            last[j]=i;
        }
    return 0;
}

int main()
{
    while(~scanf("%d",&n))
    {
        int i,j,J;
        memset(map,0,sizeof(map));
        for(i=0; i<n; i++)
        {
            int M;
            scanf("%d",&M);
            getchar();
            getchar();
            getchar();
            scanf("%d",&m);
            getchar();
            for(j=0; j<m; j++)
            {
                scanf("%d",&J);
                map[i][J]=1;
            }
        }
        sum=0;
        memset(last,-1,sizeof(last));
        for(i=0; i<n; i++)
        {
            memset(vis,0,sizeof(vis));
            if(find(i))
                sum++;
        }
        printf("%d\n",n-sum/2);
    }
    return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值