Watering Grass

Watering Grass

n sprinklers are installed in a horizontal strip of grass l meters long and w meters wide. Each sprinkler
is installed at the horizontal center line of the strip. For each sprinkler we are given its position as the
distance from the left end of the center line and its radius of operation.
What is the minimum number of sprinklers to turn on in order to water the entire strip of grass?`

在这里插入图片描述

Input

Input consists of a number of cases. The first line for each case contains integer numbers n, l and w
with n ≤ 10000. The next n lines contain two integers giving the position of a sprinkler and its radius
of operation. (The picture above illustrates the first case from the sample input.)

Output

For each test case output the minimum number of sprinklers needed to water the entire strip of grass.
If it is impossible to water the entire strip output ‘-1’.

Sample Input

8 20 2
5 3
4 1
1 2
7 2
10 2
13 3
16 2
19 4
3 10 1
3 5
9 3
6 1
3 10 1
5 3
1 1
9 1

Sample Output

6
2
-1

这题看似复杂其实仔细思考一下啊,它其实是不太难因为每个喷水器所形成的⚪的圆心都是在草坪的中线上的由此利用勾股就可以将其转化成一维的题目;
源代码如下

#include<cmath>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<iostream>
using namespace std;
struct node
{
    double he,ta;
} a[10100];
double dzi(double x,double y)
{
    return sqrt(x*x-y*y);
}
bool cmp(node a,node b)
{
    if(a.he==b.he)
        return a.ta>b.ta;
    return a.he<b.he;
}
int main()
{
    int n;
    double S,L;
    while(cin>>n>>S>>L)
    {
        double x,l;
        int k=0;
        int f1=0,f2=0;
        for(int i=0; i<n; i++)
        {
            cin>>x>>l;
            if(L/2>=l)
                continue;
            double z=dzi(l,L/2);
            a[k].he=x-z;
            a[k++].ta=z+x;
        }
        sort(a,a+k,cmp);
        int sum=0;
        int flag=0;
        double m=0.0,ms=0.0;
        if(a[0].he<=0)
        {
            int i=0;
            while(i<k)
            {
                int j=i;
                while(j<k&&m>=a[j].he)
                {
                    if(a[j].ta>ms)
                        ms=a[j].ta;
                    j++;
                }
                if(j==i)
                    break;
                sum++;
                m=ms;
                i=j;
                if(m>=S)
                {
                    flag=1;
                    break;
                }
            }
        }
        if(flag)
            cout<<sum<<endl;
        else
            puts("-1");
    }
    return 0;
}

不要抄袭此代码仅供参考爱你哟╰( ̄ω ̄o)
在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值