HDU - 2602 Bone Collector 动规01 背包 /// 完全背包

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
在这里插入图片描述

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14
动规01 背包 模板题,真的是裸的不能再裸了。先将原始问题一般化,欲求背包能够获得的总价值,即欲求前j个物体放入容量为m(kg)背包的最大价值f[j]——使用一个数组来存储最大价值,当j取10时,即原始问题了。而前i个物体放入容量为m(kg)的背包,又可以转化成前(i-1)个物体放入背包的问题。
话不多说上代码:

#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int f[1010];
struct node
{
    int x,y;
} a[1010];
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n,m;
        cin>>n>>m;
        memset(f,0,sizeof(f));
        for(int i=0; i<n; i++)
            cin>>a[i].x;
        for(int j=0; j<n; j++)
            cin>>a[j].y;
        for(int i=0; i<n; i++)
            for(int j=m; j>=a[i].y; j--)
            {
                f[j]=max(f[j],f[j-a[i].y]+a[i].x);
            }
        cout<<f[m]<<endl;
    }
    return 0;
}

实践才是检验真理的唯一标准;

湫湫系列故事——减肥记 HDU - 4508

对于吃货来说,过年最幸福的事就是吃了,没有之一!
  但是对于女生来说,卡路里(热量)是天敌啊!
  资深美女湫湫深谙“胖来如山倒,胖去如抽丝”的道理,所以她希望你能帮忙制定一个食谱,能使她吃得开心的同时,不会制造太多的天敌。

  当然,为了方便你制作食谱,湫湫给了你每日食物清单,上面描述了当天她想吃的每种食物能带给她的幸福程度,以及会增加的卡路里量。

Input

输入包含多组测试用例。
  每组数据以一个整数n开始,表示每天的食物清单有n种食物。
  接下来n行,每行两个整数a和b,其中a表示这种食物可以带给湫湫的幸福值(数值越大,越幸福),b表示湫湫吃这种食物会吸收的卡路里量。
  最后是一个整数m,表示湫湫一天吸收的卡路里不能超过m。

[Technical Specification]
  1. 1 <= n <= 100
  2. 0 <= a,b <= 100000
  3. 1 <= m <= 100000

Output

对每份清单,输出一个整数,即满足卡路里吸收量的同时,湫湫可获得的最大幸福值。

Sample Input

3
3 3
7 7
9 9
10
5
1 1
5 3
10 3
6 8
7 5
6

Sample Output

10
20

完全背包问题,与01背包的区别是可以无限取同一种东西。状态转移方程就变成了f[i][j] = max(f[i - 1][j],f[i][j - a[i]].x +a[i].y。但是同样如果用二维数组就会超内存,所以这道题还是用一维数组,f[j]=max(f[j],f[j-a[i].y]+a[i].x);与01背包不同的是j的循环要从小到大顺序循环

#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int f[101000];
struct node
{
    int x,y;
} a[1100];
int main()
{
    int n,m;
    while(cin>>n)
    {
        memset(f,0,sizeof(f));
        for(int i=0; i<n; i++)
            cin>>a[i].x>>a[i].y;
        cin>>m;
        for(int i=0; i<n; i++)
            for(int j=a[i].y; j<=m; j++)
            {
                f[j]=max(f[j],f[j-a[i].y]+a[i].x);
            }
        cout<<f[m]<<endl;
    }
    return 0;
}

实践才是检验真理的唯一标准;

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值