Tree Recovery UVA - 536(二叉树的遍历)

Problem Description

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.This is an example of one of her creations:

D
B
E
A
C
G
F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree).
For the tree drawn above the preorder traversal is D B A C E G F DBACEGF DBACEGF and the inorder traversal is A B C D E F G ABCDEFG ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later(but she never tried it).
Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious.
So now she asks you to write a program that does the job for her!

Input

The input file will contain one or more test cases.
Each test case consists of one line containing two strings ‘preord’ and ‘inord’, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters.(Thus they are not longer than 26 26 26 characters.)
Input is terminated by end of file.

Output

For each test case, recover Valentine’s binary tree and print one line containing the tree’s postorder traversal (left subtree, right subtree, root).

Sample Input

DBACEGF ABCDEFG
BCAD CBAD

Sample Output

ACBFGED
CDAB

题意:已知二叉树的前序遍历和中序遍历,输出后序遍历。

思路:

前序遍历:根节点–>左节点–>右节点
中序遍历:左节点–>根节点–>右节点
后序遍历:左节点–>右节点–>根节点

根据先序和中序遍历的特点,可以发现如下规律:

先序遍历的每个节点,都是当前子树的根节点。同时,以对应的节点为边界,就会把中序遍历的结果分为左子树和右子树,用这种方法求出 后 序 遍 历 {\color{Red}后序遍历 }
代码如下:

#include<iostream>
#include<cstring>
#include<string>
using namespace std;
char a[101],b[101];//存储先序和中序遍历的序列
struct node//定义节点的结构
{
    char s;
    node *l,*r;
};
node *buil(char *pre,char *in,int len)//创建后序遍历的函数
{
    int k;
    if(len<=0)
        return NULL;
    node *head=new node;
    head->s=*pre;
    char *p;
    for(p=in; p!=NULL; p++)
    {
        if(*p==*pre) //在中序遍历的序列中得到与先序相同的节点
            break;
    }
    k=p-in;
    head->l=buil(pre+1,in,k); //递归调用得到左子树
    head->r=buil(pre+k+1,p+1,len-k-1);//得到右子树
    return head;
}
void prin(node *head)  //打印后序遍历序列
{
    if(head==NULL)
        return ;
    prin(head->l);
    prin(head->r);
    cout<<head->s;
}
int main()
{
    while(cin>>a>>b)
    {
        int len=strlen(a);
        node *head=new node;
        head=buil(a,b,len);
        prin(head);
        cout<<endl;
    }
    return 0;
}

实践是检验真理的唯一标准

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值