Python2安装setuptools/pip/pyinstaller

0x00 前言

本文撰写时python2版本已定格在2.7.x,仅作有需要旧依赖的兼容性使用。

本文基于python2经典版本2.7.6。https://www.python.org/downloads/release/python-276/

0x01 setuptools安装

pip依赖于setuptools,首先解决。

方式①:一键安装脚本

# 下载ez_setup.py,wget或者windows迅雷下单都可
wget https://bootstrap.pypa.io/ez_setup.py

# 这里的python命令可以替换为绝对路径,因为是旧项目用得不多,懒得设置环境变量
# python ez_setup.py
C:\Python27\python.exe ez_setup.py

方式②:源码安装

# python2对应setuptools要选旧版本,此处推荐36.5.0
https://pypi.org/project/setuptools/36.5.0

# 同样任意方式下载
wget https://files.pythonhosted.org/packages/a4/c8/9a7a47f683d54d83f648d37c3e180317f80dc126a304c45dc6663246233a/setuptools-36.5.0.zip

# 安装,一定要cd进去,否则会出现路径错误
cd setuptools-36.5.0
python setup.py install

0x02 pip安装

pip兼容性不错,选择最新版也能兼容旧版本python2,下载最新版即可。

https://pypi.org/project/pip/#files

# 解压后一定要cd进去,否则会出现路径错误
cd pip

python setup.py install

# 至此可以使用命令,但不正常
python -m pip install wheel

# 在报错堆栈里misc.py 710行把url固定为清华源即可
# 原因是netloc有bug,把url自动加了前缀"https://"
misc.py:710  url="https://pypi.tuna.tsinghua.edu.cn/simple"

0x03 pyinstaller安装

# pyinstaller下载安装
pyinstaller v2.1是python2受支持的最后一个版本。https://github.com/pyinstaller/pyinstaller/releases/tag/v2.1

# 安装pyinstaller本体
cd PyInstaller-2.1
python2 setup.py install

# Windows下安装pywin32依赖包
python2 -m pip install pywin32

# distribute依赖包下载安装
https://pypi.org/project/distribute/0.6.49
cd distribute-0.6.49
python2 setup.py install

# 测试
Python27(python2根目录)\Scripts\pyinstaller.exe -F test.py

 

©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页