Network Saboteur-POJ2531

Network Saboteur
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 14300 Accepted: 7023

Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts.
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks.
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him.
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000).
Output file must contain a single integer -- the maximum traffic between the subnetworks.

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.

Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90

Source

Northeastern Europe 2002, Far-Eastern Subregion
题目意思:首先的搞清楚矩阵表示的意思

0 50 30   //表示1-1的距离为0,1-2的距离为50,1-3的距离为30

50 0 40//表示2-1的距离为50,对称。。。。。

30 40 0

将这些点任意分成两部分,求其中一部分点到另外一部分点的权值的和的最大值

代码如下:

#include<iostream>
#include<string.h>
#include<cstdio>
#include<algorithm>
using namespace std;
int maxn,matrix[25][25],vis[25],n;
void dfs(int index,int sum)
{
	vis[index]=1;
	for(int i=0;i<n;i++){
		if(vis[i]){//如果为同一个集合,则之间的距离会为零,所以传过来的sum值需要减去这一部分 
			sum-=matrix[index][i];
		}
		else{
			sum+=matrix[index][i];
		}
	}
	maxn=max(maxn,sum);
	for(int i=index+1;i<n;i++){
		dfs(i,sum);
		vis[i]=0;	
	}
}
int main()
{
	while(~scanf("%d",&n)){
		memset(vis,0,sizeof(vis));
		for(int i=0;i<n;i++){
			for(int j=0;j<n;j++){
				scanf("%d",&matrix[i][j]);
			} 
		}
		maxn=0;
		dfs(0,0);
		printf("%d\n",maxn);
	}
	return 0;
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值