HDU-3278Catch That Cow

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 115360 Accepted: 36046

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

思路:基本的bfs题目。没啥好说的,思路都写在注释上了
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
struct node
{
	int x,y,step;
}st;
queue<node>q;
int vis[200000];//标记数组,判断这个点是否走过
int n,m;
int flat;
int bfs()
{
	while(!q.empty())
	{
		q.pop();//将队列清空 
	} 
	memset(vis,0,sizeof(vis));
	vis[st.x]=1;//标记牧场的位置,防止其走回来 
	q.push(st);
	while(!q.empty()){//如果队列中有数字,则继续循环 
		node now=q.front();
		if(now.x==m) return now.step;
		q.pop();
		for(int j=0;j<3;j++){//有三种情况 
			node next=now;
			if(j==0){
				next.x+=1;
			}
			else if(j==1){
				next.x-=1;
			}
			else{
				next.x*=2;
			}
			++next.step;
			if(next.x==m){
				return next.step;
			}
			if(next.x>=0&&next.x<=200000&&!vis[next.x]){//判断是否越界与其是否被访问 
				vis[next.x]=1;//这个地方写成==了,疯狂wa,后来看了别人的博客,把变量名
				q.push(next); //全部改成和他的一样才发现o(TヘTo)
			} 
		}
	}
	return 0;
} 
int main()
{
	while(~scanf("%d %d",&n,&m))
	{
		st.x=n,st.step=0;
		printf("%d\n",bfs());
	}
	return 0;
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值