HDU1536-S-Nim(SG函数和异或处理)

题目链接                                    S-Nim

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9613    Accepted Submission(s): 3967

 

Problem Description

Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:

  The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.

  The players take turns chosing a heap and removing a positive number of beads from it.

  The first player not able to make a move, loses.

Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:

  Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).

  If the xor-sum is 0, too bad, you will lose.

  Otherwise, move such that the xor-sum becomes 0. This is always possible.


It is quite easy to convince oneself that this works. Consider these facts:

  The player that takes the last bead wins.

  After the winning player's last move the xor-sum will be 0.

  The xor-sum will change after every move.


Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.

Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?

your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.

Input

Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by a 0 on a line of its own.

Output

For each position: If the described position is a winning position print a 'W'.If the described position is a losing position print an 'L'. Print a newline after each test case.

 

Sample Input

2 2 5

3

2 5 12

3 2 4 7

4 2 3 7 12

 

5 1 2 3 4 5

3

2 5 12

3 2 4 7

4 2 3 712

0

Sample Output

LWW

WWL

Source

Norgesmesterskapet 2004

题目意思:就是首先给你一个数s,输入s个数的集合,接下来的操作只能取与这集合相对应的石子,接下来一行输入一个数m,表示

m次操作,然后输入一个n,表示有n堆石子,如果先手胜出输出L,否则输出W,当然得一连串输出这m个字母。

思路:运用sg函数和xor处理,就是一个裸题了。

tle代码:这个原始得模板比较low,容易超时。后来发现超时是因为访问数组的问题,如果设置为bool就不超时了。

#include<iostream>
#include<cstdio>
#include<string.h>
#include<string>
using namespace std;
const int maxn=10010;
int sg[maxn],oper[maxn],temp[maxn],k[maxn];
int s;
void getsg()
{
	memset(sg,0,sizeof(sg));
	for(int i=0;i<10010;i++){
		memset(temp,0,sizeof(temp));
		for(int j=0;j<s&&oper[j]<=i;j++){
			temp[sg[i-oper[j]]]=1;//如果到达的前一点均为必胜,那么这个点为必败 
		}                        //否则为必胜 
		for(int j=0;j<=s;j++){//深入了解你会发现sg会使一个周期 
			if(temp[j]==0){//如果都出现了,那么不会进行赋值了,为必败 
				sg[i]=j;//如果有第一个必败点,那么记录下来,这个点变为必胜点 
				break;
			}
		}
	}
}
int main()
{
	char p[1005];
	int m,a,b,c;
	string str;
	while(scanf("%d",&s),s){
		for(int i=0;i<s;i++) scanf("%d",&oper[i]);
		getsg();
		scanf("%d",&m);
		for(int i=0;i<m;i++){
		    scanf("%d",&a);
		    scanf("%d",&c);
		    c=sg[c];//异或操作就是将每堆石子进行异或, 
		    for(int j=1;j<a;j++){
			    scanf("%d",&b);
			    c=c^sg[b]; 
		    }
			if(c==0) p[i]='L';如果异或值为零 
			else p[i]='W';					
		}
		printf("%s\n",p); 
	} 
} 

参考的好用板子:https://blog.csdn.net/qq_40932661/article/details/81308957

AC代码①:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <algorithm>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const int maxn = 10010;
int sg[maxn], s[maxn],k;//sg函数值 s是可取的数(1,3,4) 
bool vis[maxn];//标记 
void SG(int n) {
	memset(sg, 0, sizeof(sg));
	for(int i = 1; i < maxn; i++) {
		memset(vis, false, sizeof(vis));
		for(int j = 0; j < n && s[j] <= i; j++)//s[j] <= i 表示后继     j < n 共有n种取法 
			vis[sg[i-s[j]]] = true;//把后继的sg值标记,出现过了 
		for(int j = 0; j <= maxn; j++) {
			if(!vis[j]) {//第一个没有出现的数字   sort优化 
				sg[i] = j;
				break;
			}
		}
	}
} 
int main() {
	int m, l, x;
	while(scanf("%d", &k),k) {
		for(int i = 0; i < k; i++)
			scanf("%d", &s[i]);
		sort(s, s+k);//优化 
		SG(k);
		scanf("%d", &m);
		while(m--) {
			scanf("%d", &l);
			int sum = 0;
			while(l--) {
				scanf("%d", &x); 
				sum ^= sg[x];//每一堆的异或和 
			}
			if(sum == 0)//必败 P 
				printf("L");
			else// 必胜 N 
				printf("W");
		}
		printf("\n");
	}
} 

AC代码②:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <algorithm>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
int sg[10010], s[110],k;//意义同上 
int sG(int x) {
	if(sg[x] != -1) //已经计算过直接返回 
		return sg[x];
	bool vis[110];
	memset(vis, 0, sizeof(vis));//标记 
	for(int i = 0; i < k; i++) {//跑可取数 
		if(x >= s[i]) {//如果是后继 
			sG(x-s[i]);//递归得到后继的sg值 
			vis[sg[x-s[i]]] = 1;//把后继的sg值标记出现过 
		}
	}
	int e;
	for(int i = 0;;i++) {//第一个没有出现的 
		if(!vis[i]) {
			e = i;
			break;
		}
	}
	return sg[x] = e;//返回值 
}
int main() {
	int m, l, x;
	while(~scanf("%d", &k)&&k) { 
		for(int i = 0; i < k; i++)
			scanf("%d", &s[i]);
		memset(sg, -1, sizeof(sg));//初始化-1 
		sort(s, s+k);//排序 
		scanf("%d", &m);
		while(m--) {
			scanf("%d", &l);
			int sum = 0;
			while(l--) {
				scanf("%d", &x);
				sum ^= sG(x);
			}
			if(sum == 0)
				printf("L");
			else
				printf("W");
		}
		printf("\n");
	}
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值