hdu5904-LCIS

题目链接

                                             LCIS

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1386    Accepted Submission(s): 608


 

Problem Description

Alex has two sequences a1,a2,...,an and b1,b2,...,bm . He wants find a longest common subsequence that consists of consecutive values in increasing order.

 

 

Input

There are multiple test cases. The first line of input contains an integer T , indicating the number of test cases. For each test case:

The first line contains two integers n and m (1≤n,m≤100000) -- the length of two sequences. The second line contains n integers: a1,a2,...,an (1≤ai≤106) . The third line contains n integers: b1,b2,...,bm (1≤bi≤106) .

There are at most 1000 test cases and the sum of n and m does not exceed 2×106 .

 

 

Output

For each test case, output the length of longest common subsequence that consists of consecutive values in increasing order.

 

 

Sample Input

3

3 3

1 2 3

3 2 1

10 5

1 23 2 32 4 3 4 5 6 1 

2 3 4 5 1

1

2

1

 

 

Sample Output

1

5

0

 

 

Source

BestCoder Round #87

思路:这是一道简单题目,求两数串的最长公共子序列,且子序列为1的递增。但是我一来就wa了TAT,直接开二维数组dp是不行的,数据范围约束了,所以就有了以下的状态转移方程,

dp[temp]=dp[temp-1]+1;(temp为输入的值,这样能保证是连续上升子序列,还不重复,想想为什么)

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string.h>
#define in(x) scanf("%d",&x)
#define out(x) printf("%d\n",x)
using namespace std;
const int maxn=200005;
int k[maxn],p[maxn];
int main()
{
	int t,n,m,temp,smax;
	in(t);
	while(t--){
		in(n),in(m);
		smax=-99;
		memset(k,0,sizeof(k));
		memset(p,0,sizeof(p));
		for(int i=0;i<n;i++){
			in(temp);
			k[temp]=k[temp-1]+1;
		}
		for(int i=0;i<m;i++){
			in(temp);
			p[temp]=p[temp-1]+1;
			smax=max(smax,min(k[temp],p[temp]));//取min因为得是最长公共子序列
		}
		out(smax);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值