POJ 3735 Training little cats(矩阵快速幂)

Training little cats
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 11787 Accepted: 2892
Description

Facer’s pet cat just gave birth to a brood of little cats. Having considered the health of those lovely cats, Facer decides to make the cats to do some exercises. Facer has well designed a set of moves for his cats. He is now asking you to supervise the cats to do his exercises. Facer’s great exercise for cats contains three different moves:
g i : Let the ith cat take a peanut.
e i : Let the ith cat eat all peanuts it have.
s i j : Let the ith cat and jth cat exchange their peanuts.
All the cats perform a sequence of these moves and must repeat it m times! Poor cats! Only Facer can come up with such embarrassing idea.
You have to determine the final number of peanuts each cat have, and directly give them the exact quantity in order to save them.

Input

The input file consists of multiple test cases, ending with three zeroes “0 0 0”. For each test case, three integers n, m and k are given firstly, where n is the number of cats and k is the length of the move sequence. The following k lines describe the sequence.
(m≤1,000,000,000, n≤100, k≤100)

Output

For each test case, output n numbers in a single line, representing the numbers of peanuts the cats have.

Sample Input

3 1 6
g 1
g 2
g 2
s 1 2
g 3
e 2
0 0 0
Sample Output

2 0 1

这个也是构造矩阵,
这里写图片描述
这里三个操作可以合并的,也就是不用每次都构造一个新的矩阵,具体见代码

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <stdio.h>
#include <algorithm>
#include <math.h>

using namespace std;
typedef long long int LL;
int n,k;
LL mod;
struct Node
{
    LL a[105][105];
};
char m[10];
Node mutiply(Node a,Node b)
{
    Node c;
    memset(c.a,0,sizeof(c.a));
    for(int i=1;i<=n+1;i++)
    {
        for(int j=1;j<=n+1;j++)
        {
            if(!a.a[i][j]) continue;
            for(int k=1;k<=n+1;k++)
                c.a[i][k]+=a.a[i][j]*b.a[j][k];
        }
    }
    return c;
}
Node get(Node a,LL x)
{
    Node c;
    memset(c.a,0,sizeof(c.a));
    for(int i=1;i<=n+1;i++)
        c.a[i][i]=1;
    for(x;x;x>>=1)
    {
        if(x&1) c=mutiply(c,a);
        a=mutiply(a,a);
    }
    return c;
}
int main()
{
    int x;int y;
    while(scanf("%d%lld%d",&n,&mod,&k)!=EOF)
    {
        if(n==0&&mod==0&&k==0)
            break;
        Node a;
        memset(a.a,0,sizeof(a.a));
        for(int i=1;i<=n+1;i++)
            a.a[i][i]=1;
       for(int i=1;i<=k;i++)
        {

            scanf("%s",m);
            if(m[0]=='g')
            {
                scanf("%d",&x);
                a.a[x][n+1]++;
            }
            else if(m[0]=='e')
            {
                scanf("%d",&x);
                for(int j=1;j<=n+1;j++)
                a.a[x][j]=0;
            }
            else if(m[0]=='s')
            {
                scanf("%d%d",&x,&y);
                for(int j=1;j<=n+1;j++)
                swap(a.a[x][j],a.a[y][j]);
            }
        }
        a=get(a,mod);
        Node c;
        memset(c.a,0,sizeof(c.a));
        c.a[n+1][1]=1;
        a=mutiply(a,c);
        for(int i=1;i<=n;i++)
            printf("%lld ",a.a[i][1]);
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是Java解决POJ3233—矩阵幂序列问题的代码和解释: ```java import java.util.Scanner; public class Main { static int n, k, m; static int[][] A, E; public static void main(String[] args) { Scanner sc = new Scanner(System.in); n = sc.nextInt(); k = sc.nextInt(); m = sc.nextInt(); A = new int[n][n]; E = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { A[i][j] = sc.nextInt() % m; E[i][j] = (i == j) ? 1 : 0; } } int[][] res = matrixPow(A, k); int[][] ans = matrixAdd(res, E); printMatrix(ans); } // 矩阵乘法 public static int[][] matrixMul(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { for (int k = 0; k < n; k++) { c[i][j] = (c[i][j] + a[i][k] * b[k][j]) % m; } } } return c; } // 矩阵快速幂 public static int[][] matrixPow(int[][] a, int b) { int[][] res = E; while (b > 0) { if ((b & 1) == 1) { res = matrixMul(res, a); } a = matrixMul(a, a); b >>= 1; } return res; } // 矩阵加法 public static int[][] matrixAdd(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { c[i][j] = (a[i][j] + b[i][j]) % m; } } return c; } // 输出矩阵 public static void printMatrix(int[][] a) { for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { System.out.print(a[i][j] + " "); } System.out.println(); } } } ``` 解释: 1. 首先读入输入的n、k、m和矩阵A,同时初始化单位矩阵E。 2. 然后调用matrixPow函数求出A的k次幂矩阵res。 3. 最后将res和E相加得到结果ans,并输出。 4. matrixMul函数实现矩阵乘法,matrixPow函数实现矩阵快速幂,matrixAdd函数实现矩阵加法,printMatrix函数实现输出矩阵。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值