ZOJ 3332 Strange Country II

Strange Country II

Time Limit: 1 Second       Memory Limit: 32768 KB       Special Judge

You want to visit a strange country. There are n cities in the country. Cities are numbered from 1 to n. The unique way to travel in the country is taking planes. Strangely, in this strange country, for every two cities A and B, there is a flight from A to B or from B to A, but not both. You can start at any city and you can finish your visit in any city you want. You want to visit each city exactly once. Is it possible?

Input

There are multiple test cases. The first line of input is an integer T (0 < T <= 100) indicating the number of test cases. Then T test cases follow. Each test case starts with a line containing an integer n (0 < n<= 100), which is the number of cities. Each of the next n * (n - 1) / 2 lines contains 2 numbers AB (0 < AB <= nA != B), meaning that there is a flight from city A to city B.

Output

For each test case:

  • If you can visit each city exactly once, output the possible visiting order in a single line please. Separate the city numbers by spaces. If there are more than one orders, you can output any one.
  • Otherwise, output "Impossible" (without quotes) in a single line.

Sample Input

3
1
2
1 2
3
1 2
1 3
2 3

Sample Output

1
1 2

1 2 3

dfs

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>

using namespace std;
int a[105][105];
int ans[105];
int vis[105];
int n;
bool res;
void dfs(int x,int cnt)
{
	if(cnt>n)
		return;
	if(res)
	{
		ans[cnt]=x;
		return;
	}
    if(cnt==n)
	{
		res=true;
		ans[cnt]=x;
		return;

	}
    for(int i=1;i<=n;i++)
	{
		if(a[x][i]&&!vis[i])
		{
			vis[i]=1;
			dfs(i,cnt+1);
			vis[i]=0;
			if(res)
			{
				ans[cnt]=x;
				return;
			}

		}
	}
}
int main()
{
	int t;
	int x,y;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		memset(a,0,sizeof(a));
		for(int i=1;i<=n*(n-1)/2;i++)
		{
			scanf("%d%d",&x,&y);
			a[x][y]=1;
		}
		memset(vis,0,sizeof(vis));
		res=false;
		for(int i=1;i<=n;i++)
		{
			vis[i]=1;
			dfs(i,1);
			vis[i]=0;
			if(res)
				break;
		}
		if(!res)
		{
           printf("Impossible\n");
		   continue;
		}
		for(int i=1;i<=n;i++)
		{
			if(i!=n)
			printf("%d ",ans[i]);
			else
				printf("%d",ans[i]);
		}
		printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值