线段树(询问、插入)&树状数组POJ2352Starts解题报告

Stars
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 37710 Accepted: 16424

Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it’s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

Source
Ural Collegiate Programming Contest 1999
由于y坐标是递增的,所以关注x坐标就好。假设当前输入的坐标为(x,y),线段树维护已经输入的所有坐标中,横坐标范围在[0,x]内的星星数sum,sum即为当前点(x,y)的level值。然后将点(x,y)的x值插入线段树,modify函数。

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
const int maxn=15111,maxm=32111;
int ans[maxn];
struct
{
    int L,R;
    int sum;
}SegTree[maxm*4];
void makeSegTreeee(int Node,int L,int R)
{
    SegTree[Node].L=L; SegTree[Node].R=R; SegTree[Node].sum=0;
    if(L==R) return;
    int mid=(L+R)/2;
    makeSegTreeee(Node*2,L,mid);
    makeSegTreeee(Node*2+1,mid+1,R);
}
void modify(int Node,int x)
{
    SegTree[Node].sum++;
    if(SegTree[Node].L==SegTree[Node].R) return;
    int mid=(SegTree[Node].L+SegTree[Node].R)>>1;
    if(x<=mid) modify(Node*2,x);
    else modify(Node*2+1,x);
}
int query(int Node,int L,int R)
{
    if(SegTree[Node].R==R&&SegTree[Node].L==L)//刚好询问的是本区间
       return(SegTree[Node].sum);
    int mid=(SegTree[Node].L+SegTree[Node].R)/2;
    if(R<=mid)
       query(Node<<1,L,R);//询问左子树
    else if(mid+1<=L)
       query(Node<<1|1,L,R);//询问右子树
    else
     return(query(Node*2,L,mid)+query(Node*2+1,mid+1,R));//询问左右子树
}
int main()
{
    freopen("output.txt","w",stdout);
    freopen("input.txt","r",stdin);
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        makeSegTreeee(1,0,32000);
        memset(ans,0,sizeof(ans));
        for(int i=1,x,y,tmp_x;i<=n;i++)
        {
            scanf("%d %d",&x,&y);
            tmp_x=query(1,0,x);
            ans[tmp_x]++;
            modify(1,x);
        }
        for(int i=0;i<n;i++) printf("%d\n",ans[i]);
    }
    return 0;
}

以下是树状数组解法:

#include<stdio.h>
#include<string.h>
const int N = 32010;
int sum[N], level[N];

int lowbit(int x)
{
    return x & (-x);
}

int get_sum(int x)
{
    int s = 0;
    while(x > 0)
    {
        s += sum[x];
        x -= lowbit(x);
    }
    return s;
}

void insert(int x)
{
    while(x < 32005)
    {
        sum[x]++;
        x += lowbit(x);
    }
}

int main()
{
    int n, x, y, i;
    while(~scanf("%d",&n))
    {
        memset(sum, 0, sizeof(sum));
        memset(level, 0, sizeof(level));
        for(i = 0; i < n; i++)
        {
            scanf("%d%d",&x,&y);
            level[get_sum(x+1)]++;
            insert(x+1); //更新sum[i]的值
        }
        for(i = 0; i < n; i++)
            printf("%d\n",level[i]);
    }
    return 0;
}
//sum[i]表示x不大于i的点的数目
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值