最大生成树POJ2263Heavy Cargo解题报告

Heavy Cargo
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3877 Accepted: 2060
Description
Big Johnsson Trucks Inc. is a company specialized in manufacturing big trucks. Their latest model, the Godzilla V12, is so big that the amount of cargo you can transport with it is never limited by the truck itself. It is only limited by the weight restrictions that apply for the roads along the path you want to drive.

Given start and destination city, your job is to determine the maximum load of the Godzilla V12 so that there still exists a path between the two specified cities.
Input
The input will contain one or more test cases. The first line of each test case will contain two integers: the number of cities n (2<=n<=200) and the number of road segments r (1<=r<=19900) making up the street network.
Then r lines will follow, each one describing one road segment by naming the two cities connected by the segment and giving the weight limit for trucks that use this segment. Names are not longer than 30 characters and do not contain white-space characters. Weight limits are integers in the range 0 - 10000. Roads can always be travelled in both directions.
The last line of the test case contains two city names: start and destination.
Input will be terminated by two values of 0 for n and r.
Output
For each test case, print three lines:
• a line saying “Scenario #x” where x is the number of the test case
• a line saying “y tons” where y is the maximum possible load
• a blank line
Sample Input
4 3
Karlsruhe Stuttgart 100
Stuttgart Ulm 80
Ulm Muenchen 120
Karlsruhe Muenchen
5 5
Karlsruhe Stuttgart 100
Stuttgart Ulm 80
Ulm Muenchen 120
Karlsruhe Hamburg 220
Hamburg Muenchen 170
Muenchen Karlsruhe
0 0
Sample Output
Scenario #1
80 tons

Scenario #2
170 tons
Source
Ulm Local 1998

这题跟POJ1797一个模型。
难点是将城市转换成数组下标。就是一个string对应一个int,因此可以用map

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
#define MAXN 205
#define INF 0xffffff
using namespace std;
int father[MAXN];
struct Road{
    int a,b,w;
}road[20000];
int findRoot(int x){
    return father[x]==x?x:father[x]=findRoot(father[x]);
}
bool cmp(Road a,Road b){
    return a.w>b.w;
}
int main(){
    freopen("input.txt","r",stdin);
    freopen("output.txt","w",stdout);
    int n,r,cases=1;
    while(scanf("%d%d",&n,&r)&&n){
        map<string,int> MyMap;
        char a[35],b[35],from[35],to[35];
        int _count=1;
        for(int i=0;i<r;i++){
            scanf("%s%s%d",&a,&b,&road[i].w);
            if(!MyMap[a])//a城市还未出现过
                MyMap[a]=_count++;//给a城市编号
            if(!MyMap[b])//b城市未出现过
                MyMap[b]=_count++;//给b城市编号
            road[i].a=MyMap[a],road[i].b=MyMap[b];
        }
        scanf("%s%s",&from,&to);
        sort(road,road+r,cmp);
        for(int i=0;i<n;i++)father[i]=i;//初始化集合
        int ans=INF;
        for(int i=0;i<r;i++){//对于每一边
            int rootA=findRoot(road[i].a),rootB=findRoot(road[i].b);//每一边两个顶点
            if(rootA!=rootB){
                father[rootA]=rootB;
                if(ans>road[i].w){
                    ans=road[i].w;
                }
                if(findRoot(MyMap[from])==findRoot(MyMap[to]))
                    break;
            }
        }
        printf("Scenario #%d\n%d tons\n\n",cases++,ans);
    }
      return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值