Number Sequence

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. 
Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). 
Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5
#include <iostream>
using namespace std;

int main()
{
    int n; int a, b;
    cin >> a >> b >> n;
    while (a != 0 && b != 0 && n != 0)
    {
        int sum = 0;
        if (n == 1)
            cout << 1 << endl;
        else if (n == 1)
            cout << 1 << endl;
        else
        {    //value_n_1表示f(n-1)  value_n_2表示f(n-2)
            int sum; int value_n_1 = 1; int value_n_2 = 1;
            int N = n % 49;
            for (int i = 3; i <= N; i++)
            {
                sum = (a * value_n_1 + b * value_n_2) % 7;//sum表示f(n)
                value_n_2 = value_n_1;//更新f(n-2)的值,等于这一次循环的f(n-1)的值
                value_n_1 = sum;//更新f(n-1)的值,等于这一次循环的f(n)的值
            }
            cout << sum << endl;
        }
        cin >> a >> b >> n;
    }

    return 0;
}

本题初看是一道典型的递归题目,用递归也可以解出正确结果,但内存会爆,且时间也会超。同样即使改为循环,虽然使得内存合法,但时间依然会超。从n=100000000,来看本题必然涉及到算法的优化问题。
从取模的性质可知道f(n)、f(n-1)、f(n-2)小于7,其取值只有0~6这7中可能。因此f(n-1)和f(n-2)总共有49种可能,因此f(n)=f(n%49);
这里把用循环的形式写出的代码贴出来。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值