ZOJ-1094,POJ-2246 Matrix Chain Multiplication

2 篇文章 0 订阅

Matrix multiplication problem is a typical example of dynamical programming.

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.
For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix.
There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).
The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

Input Specification

Input consists of two parts: a list of matrices and a list of expressions.
The first line of the input file contains one integer
n (1 <= n <= 26), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.
The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line } <EOF>
Line       = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"

Output Specification

For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))

Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500
15125


题目大意:两个矩阵相乘,会有一个乘法次数,比如:A(50*10),B(10*20),A*B的乘法次数为50*10*20=10000次。现在给N个矩阵及它们的行列数。接下来有若干个乘法算式,求每个算式的乘法次数。


分析:通过这道题,联系C++标准库中stack和map的用法。用map储存每个矩阵的行列数。用stack来计算。

           若仅有一个矩阵,则乘法次数为0。

           如果当前字符为矩阵编号,入栈;为')'则选取前两个矩阵出栈统计乘法次数,并将新矩阵的行列数用map储存,再次入栈。


代码如下:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<stack>
#include<map>
#include<queue>
#include<vector>
using namespace std;
int N;
char ch;

struct Node
{
	int x,y;
};
map <char,Node> matrix;
int main()
{
	cin>>N;
	for(int i=0;i<N;i++)
	{
		cin>>ch;
		cin>>matrix[ch].x>>matrix[ch].y;
	}
	string st;
	while(cin>>st)
	{
		if(st.size()==1&&st[0]!='('&&st[0]!=')')
		{
			cout<<0<<endl;
		}
		else
		{
			stack<Node> s;
			int ans=0,i;
			for(i=0;i<st.size();i++)
			{
				//cout<<'a'<<endl;
				if(st[i]=='(') continue;
				if(st[i]==')')
				{
				
					Node b=s.top();//取栈顶两个矩阵。
					s.pop();
					Node a=s.top();
					s.pop();
					if(a.y!=b.x)//不满足矩阵相乘的条件,错误。
					{
						cout<<"error"<<endl;
						break;
					}
					ans+=a.y*b.y*a.x;//计算乘法次数。
					Node temp={a.x,b.y};//二者乘法结果入栈。
					s.push(temp);
				}
				else s.push(matrix[st[i]]);
			}
			if(i==st.size()) cout<<ans<<endl;
		}
	}
	return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值