HDU 4627(最小公倍数最大问题)

                       HDU 4627

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
 

Description

There are many unsolvable problem in the world.It could be about one or about zero.But this time it is about bigger number. 
Given an integer n(2 <= n <= 10  9).We should find a pair of  positive integer a, b so that a + b = n and [a, b] is as large as possible. [a, b] denote the least common multiplier of a, b.
 

Input

The first line contains integer T(1<= T<= 10000),denote the number of the test cases. 
For each test cases,the first line contains an integer n.
 

Output

For each test cases,  print the maximum [a,b] in a line.
 

Sample Input

3 2 3 4
 

Sample Output

1 2 3
 
此题的话,因为一个数n由两个正整数a+b得来,所以可以先确定a和b的范围,是从1到n/2 
 因为从n/2+1到n,是和前半部分重复,不用计算 
 然后,就用辗转相除法,a,b互质,输出最大的 LCM(a, b),即a,b的最小公倍数最大。
  注意:这种算法易懂,但是很容易超时,自己做的时候就是
 
#include <stdio.h>
int main()
{
    int a,b,c;
    int max,min,t1,t2;
    int i,n,T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        max=0;
        for(i=1; i<=n/2; i++)
        {
            a=i;
            b=n-i;
            a>b?t1=a:t1=b;
            t2=n-t1;
            while(t2)
            {
                c=t1%t2;
                t1=t2;
                t2=c;
            }
            min=a*b/t1;
            if(min>max)
                max=min;
        }
        printf("%d\n",max);
    }
    return 0;
}

 

另外还有一种,这是一种奇偶求法,很简单巧妙,经某ACM大神指点得知

#include <stdio.h>

int main()
{
    int n,T;
    long long max;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        max=0;
        if (n==2) printf("1\n");
        else
        {
            if (n%2==0)
            {
                max=n/2;
                if (max%2==0) max=(max+1)*(max-1);
                else max=(max+2)*(max-2);
            }
            else
            {
                max=n/2;
                max=max*(max+1);
            }
            printf("%I64d\n",max);
        }
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/hfc-xx/p/4655734.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值