12100 Printer Queue(优先队列)

12100 Printer Queue12

 

   The only printer in the computer science students’ union is experiencing an extremely heavy workload. Sometimes there are a hundred jobs in the printer queue and you may have to wait for hours to get a single page of output.

   Because some jobs are more important than others, theHacker General has invented and implemented a simple priority system for the print job queue. Now, each job is assigned a priority between 1 and 9 (with 9 being the highest

priority, and 1 being the lowest), and the printer operates

as follows.

   The first job J in queue is taken from the queue.

   If there is some job in the queue with a higher priority than job J, then move J to the end of thequeue without printing it.

   Otherwise, print job J (and do not put it back in the queue).

In this way, all those important muffin recipes that the Hacker General is printing get printed very quickly. Of course, those annoying term papers that others are printing may have to wait for quite some time to get printed, but that’s life.

Your problem with the new policy is that it has become quite tricky to determine when your print job will actually be completed. You decide to write a program to figure this out. The program will be given the current queue (as a list of priorities) as well as the position of your job in the queue, and must then calculate how long it will take until your job is printed, assuming that no additional jobs will be added to the queue. To simplify matters, we assume that printing a job always takes exactly one minute, and that adding and removing jobs from the queue is instantaneous.

Input

One line with a positive integer: the number of test cases (at most 100). Then for each test case:

One line with two integers n and m, where n is the number of jobs in the queue (1 ≤ n ≤ 100)and m is the position of your job (0 ≤ m ≤ n − 1). The first position in the queue is number 0,the second is number 1, and so on.

One line with n integers in the range 1 to 9, giving the priorities of the jobs in the queue. The first integer gives the priority of the first job, the second integer the priority of the second job, and so on.

Output

For each test case, print one line with a single integer; the number of minutes until your job is completely printed, assuming that no additional print jobs will arrive.

 

Sample Input

3

1 0

5

4 2

1 2 3 4

6 0

1 1 9 1 1 1

Sample Output

1

2

5

 

题解:优先队列问题,模拟完成即可。

 

注意:

   priority_queue<int> v 对v队列的根据优先级从大到小排序

 

   push(x) 将x压入队列的末端

   pop() 弹出队列的第一个元素(队顶元素),注意此函数并不返回任何值

 

   front() 返回第一个元素(队顶元素)

 

   back() 返回最后被压入的元素(队尾元素)

 

  empty() 当队列为空时,返回true

 

  size() 返回队列的长度

  top() 返回优先队列中有最高优先级的元素

 

 

 

#include <iostream>

#include <cstdio>

#include <queue>
using namespace std;
int main()
{
    int t;
    scanf("%d", &t);
    while (t--)
    {
        queue<int> q;
        priority_queue<int> v;
        int n, m;
        scanf("%d%d", &n, &m);
        int i;
        for (i = 0; i < n; ++i)
        {
           int a;
            scanf("%d", &a);
            q.push(a);
            v.push(a);
        }
        while (true)
        {
            int x = q.front();
            q.pop();
            if (m == 0)  //如果m==0,则证明现在打印的是目标任务
            {
                if (x != v.top())  //如果队列中还有优先级比x高的..
                {
                   m = v.size() - 1;//下标是从0开始的
                    q.push(x);//将该任务放到队尾
                }
                else
                {
                    break;
                }
            }
            else    //如果现在的任务还不是目标任务
            {
               --m;
                if (x != v.top())
                {
                    q.push(x);
                }
                else
                {
                    v.pop();
                }
            }
        }
       printf("%d\n", n - q.size());//q.size是全部打印结束后q队列的长度
    }
    return 0;

}

 

转载于:https://www.cnblogs.com/hfc-xx/p/4659829.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值