UVA12100 Printer Queue(STL)

题意:

The only printer in the computer science students’ union is experiencing an extremely heavy workload. Sometimes there are a hundred jobs in the printer queue and you may have to wait for hours to get a single page of output. 

Because some jobs are more important than others, the Hacker General has invented and implemented a simple priority system for the print job queue. Now, each job is assigned a priority between 1 and 9 (with 9 being the highest priority, and 1 being the lowest), and the printer operates as follows.

• The first job J in queue is taken from the queue. 

• If there is some job in the queue with a higher priority than job J, then move J to the end of the queue without printing it. 

• Otherwise, print job J (and do not put it back in the queue).

In this way, all those important muffin recipes that the Hacker General is printing get printed very quickly. Of course, those annoying term papers that others are printing may have to wait for quite some time to get printed, but that’s life. 

Your problem with the new policy is that it has become quite tricky to determine when your print job will actually be completed. You decide to write a program to figure this out. The program will be given the current queue (as a list of priorities) as well as the position of your job in the queue, and must then calculate how long it will take until your job is printed, assuming that no additional jobs will be added to the queue. To simplify matters, we assume that printing a job always takes exactly one minute, and that adding and removing jobs from the queue is instantaneous.
 

Input:

One line with a positive integer: the number of test cases (at most 100). Then for each test case:

• One line with two integers n and m, where n is the number of jobs in the queue (1 ≤ n ≤ 100) and m is the position of your job (0 ≤ m ≤ n−1). The first position in the queue is number 0, the second is number 1, and so on.

• One line with n integers in the range 1 to 9, giving the priorities of the jobs in the queue. The first integer gives the priority of the first job, the second integer the priority of the second job, and so on.

 

Output:

For each test case, print one line with a single integer; the number of minutes until your job is completely printed, assuming that no additional print jobs will arrive.
 

Sample Input:

3

1 0

5

4 2

1 2 3 4

6 0

1 1 9 1 1 1

 

Sample Output:
1

2

5

 

分析:

题意是,给你一组按照下标对应的优先级,有两种操作,1.如果队列里存在比队首优先级高的,就把队首移到队尾去。2.如果队列里没有比队首优先级高的,就把队首出队。要求的是指定下标的元素出队的次序。

我查了题解,有很多种做法,虽然题目名字叫队列,但我是用vector做出来的。声明一个结构体,用local变量记录初始下标,lev变量记录优先级。每次把vector遍历一遍,如果有比队首优先级高的,就把队首元素push_back然后erase掉队首元素,并把记录是否存在优先级更高元素的flag改成true,如果没有比队首优先级高的了,就把队首出队,然后步数记录++,如果出队的队首下标刚好是指定的下标,就代表指定元素已经出队,就此完成。

 

AC代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn = 105;
int t, n, q, ans;

struct node{
	int local;
	int lev;
}job;

vector<node>v;

int main(){
	cin>>t;
	while(t--){
		v.clear();
		cin>>n>>q;
		ans = 0;
		for(int i = 0; i < n; i++) {
			job.local = i;
			cin>>job.lev;
			v.push_back(job);
		}
		while(1){
			job = v.front();
			bool flag = false;
			for(vector<node>::iterator iter = v.begin(); iter != v.end(); iter++){
				node now = *iter;
				if(now.lev > job.lev){
					v.push_back(job);
					v.erase(v.begin());
					flag = true;
					break;
				}
			}
			if(!flag) {
				v.erase(v.begin());
				ans++;
				if(job.local == q) break;
			}
		}
		cout<<ans<<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值