*最左边的数字

Problem T
Time Limit: 1000 MS Memory Limit: 32 MB 64bit IO Format: %I64d
Submitted: 81 Accepted: 25
[Submit][Status][Web Board]
Description

Given a positive integer N, you should output the most right digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the rightmost digit of N^N.

Sample Input

2
3
4

Sample Output

7
6

HINT

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

位运算符确实是一个非常好用的工具啊!(其实有规律可循)

#include <stdio.h>
int main()
{
    long long n,t,x,m,i;
    scanf("%I64d",&m);
    for(i=0; i<m; i++)
    {
        scanf("%I64d",&n);
        t=n%10;
        x=1;
        while(n!=0)
        {
            if(n&1==1)
            {
                x*=t;
                x=x%10;
            }

            t*=t;
            t=t%10;
            n>>=1;
        }
        x=x%10;
        printf("%I64d\n",x);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值