简化版大数乘法

Description
Dear Uncle Jack is willing to give away some of his collectable CDs to his nephews. Among the titles you can find very rare albums of Hard Rock, Classical Music, Reggae and much more; each title is considered to be unique. Last week he was listening to one of his favorite songs, Nobody’s fool, and realized that it would be prudent to be aware of the many ways he can give away the CDs among some of his nephews.

So far he has not made up his mind about the total amount of CDs and the number of nephews. Indeed, a given nephew may receive no CDs at all.

Please help dear Uncle Jack, given the total number of CDs and the number of nephews, to calculate the number of different ways to distribute the CDs among the nephews.

Input
The input consists of several test cases. Each test case is given in a single line of the input by, space separated, integers N (1 ≤ N ≤ 10) and D (0 ≤ D ≤ 25), corresponding to the number of nephews and the number of CDs respectively. The end of the test cases is indicated with N = D = 0.

Output
The output consists of several lines, one per test case, following the order given by the input. Each line has the number of all possible ways to distribute D CDs among N nephews.

Sample Input
1 20
3 10
0 0
Sample Output
1
59049

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
int n,m;
void solve()
{
    int s[50];
    memset(s,0,sizeof s);
    s[0]=1;
    int up=1;
    for(int i=0;i<m;i++)
    {
        for(int j=0;j<up;j++)//现将每一位的结果算出来,在进行进位,可避免将进位后的新高位又算一遍
        {
           s[j]*=n;
          // cout<<"s[j]"<<s[j];
        }
        for(int j=0;j<up;j++)
        {
            if(s[j]>9)
            {
               s[j+1]+=s[j]/10;
               s[j]%=10;
               if(j==up-1)
                up++;
            }
        }
        // cout<<"****up="<<up<<endl;
    }

    for(int i=up-1;i>=0;i--)
        printf("%d",s[i]);
    puts("");
}
int main()
{
    while(scanf("%d%d",&n,&m)&&(n||m))
    {
        if(n==10)
        {
            printf("1");
            for(int i=0;i<m;i++)
                printf("0");
            puts("");
            continue;
        }
        solve();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值