单调栈:POJ2082:Terrible Sets

http://poj.org/problem?id=2082

Language:
Terrible Sets
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 4355 Accepted: 2254
Description

Let N be the set of all natural numbers {0 , 1 , 2 , … }, and R be the set of all real numbers. wi, hi for i = 1 … n are some elements in N, and w0 = 0.
Define set B = {< x, y > | x, y ∈ R and there exists an index i > 0 such that 0 <= y <= hi ,∑0<=j<=i-1wj <= x <= ∑0<=j<=iwj}
Again, define set S = {A| A = WH for some W , H ∈ R+ and there exists x0, y0 in N such that the set T = { < x , y > | x, y ∈ R and x0 <= x <= x0 +W and y0 <= y <= y0 + H} is contained in set B}.
Your mission now. What is Max(S)?
Wow, it looks like a terrible problem. Problems that appear to be terrible are sometimes actually easy.
But for this one, believe me, it’s difficult.
Input

The input consists of several test cases. For each case, n is given in a single line, and then followed by n lines, each containing wi and hi separated by a single space. The last line of the input is an single integer -1, indicating the end of input. You may assume that 1 <= n <= 50000 and w1h1+w2h2+…+wnhn < 109.
Output

Simply output Max(S) in a single line for each case.
Sample Input

3
1 2
3 4
1 2
3
3 4
1 2
3 4
-1
Sample Output

12
14
Source

Shanghai 2004 Preliminary

题意:
在X轴上有一系列连续的矩形,求岂能组成的最大矩形的面积;
思路:
维护一个单调递增的栈,每次弹栈记录弹出去的当前总长度,并且乘以当前高度计算当前面积;

#include <cstdio>
#include <algorithm>
using namespace std;
int mystack[50009],top;
int w[50009],h[50009];
int main()
{
    int n;
    while(scanf("%d",&n)&&n!=-1)
    {
        top=0;//栈顶指针不指向任何数据
        int ans=0 ,totalw=0,curarea=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d%d",&w[i],&h[i]);
             totalw=0,curarea=0;
            while(top>0&&h[i]<h[mystack[top-1]])
            {
                totalw+=w[mystack[top-1]];
                curarea=totalw*h[mystack[top-1]];
                ans=max(ans,curarea);
                top--;
            }
            w[i]+=totalw;//只有当出栈的时候才需要加上原来的宽度和
            mystack[top++]=i;
        }
        totalw=0,curarea=0;
        while(top>0)
        {
            totalw+=w[mystack[top-1]];
            curarea=totalw*h[mystack[top-1]];
            ans=max(ans,curarea);
            top--;
        }
        printf("%d\n",ans);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值