hdu4424:并查集

Description
The wheel of the history rolling forward, our king conquered a new region in a distant continent.
There are N towns (numbered from 1 to N) in this region connected by several roads. It’s confirmed that there is exact one route between any two towns. Traffic is important while controlled colonies are far away from the local country. We define the capacity C(i, j) of a road indicating it is allowed to transport at most C(i, j) goods between town i and town j if there is a road between them. And for a route between i and j, we define a value S(i, j) indicating the maximum traffic capacity between i and j which is equal to the minimum capacity of the roads on the route.
Our king wants to select a center town to restore his war-resources in which the total traffic capacities from the center to the other N - 1 towns is maximized. Now, you, the best programmer in the kingdom, should help our king to select this center.
Input
There are multiple test cases.
The first line of each case contains an integer N. (1 <= N <= 200,000)
The next N - 1 lines each contains three integers a, b, c indicating there is a road between town a and town b whose capacity is c. (1 <= a, b <= N, 1 <= c <= 100,000)
Output
For each test case, output an integer indicating the total traffic capacity of the chosen center town.
Sample Input
4
1 2 2
2 4 1
2 3 1
4
1 2 1
2 4 1
2 3 1
Sample Output
4
3

思路:
按照边权值从大到小排序,每次合并两个集合的时候,用集合内数目乘以边权值即为从此根到此点的容量之和,由于从大到小排序,那么最终加上的将是最小边权值

#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn=200009;
long long  pre[maxn],sum[maxn],num[maxn];
struct eadge
{
    int a,b,c;
}es[maxn];
int cmp(eadge a,eadge b)
{
    return a.c>b.c;
}
void init(int n)
{
    for(int i=1;i<=n;i++)
        pre[i]=i,num[i]=1,sum[i]=0;
}
int fin(int x)
{
    return x==pre[x]?pre[x]:fin(pre[x]);
}
void add(int aa,int bb,long long c)
{
    pre[aa]=bb;
    num[bb]+=num[aa];
    sum[bb]+=c;
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        init(n);
        for(int i=0;i<n-1;i++)
            scanf("%d%d%d",&es[i].a,&es[i].b,&es[i].c);
        sort(es,es+n-1,cmp);
        for(int i=0;i<n-1;i++)
        {
            int aa=fin(es[i].a);
            int bb=fin(es[i].b);
            if(aa==bb)
                continue;
            long long r1=num[bb]*es[i].c+sum[aa];
            long long  r2=num[aa]*es[i].c+sum[bb];
            if(r1>r2) add(bb,aa,r1-sum[aa]);
            else add(aa,bb,r2-sum[bb]);
        }
        printf("%I64d\n",sum[fin(1)]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值