HDU 5268 ZYB loves Score (BestCoder Round#44)

题目链接:ZYB loves Score


题面:

ZYB loves Score

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 395    Accepted Submission(s): 232


Problem Description
One day,ZYB participated in the BestCoder Contest 

There are four problems. Their scores are 1000,1500,2000,2500 

According to the rules of BestCoder,If you solve one problem at  x  minutes,
You will get (250-x)/250 100 %  of the original scores.

Obviously the final score must be an integer,becasue the original scores are multiple of 250

And if you make  x  wrong submissions,the score of this problem you get will be reduced by 50

For example, if you solved the first problem in 5 minutes and you make one wrong submisson, the score of this problem is 980-50=930 

To prevent very low scores,the lowest score of one problem is  40%  of its original score
 

Input
Multiple test cases, the first line contains an integer T(no more than 20), indicating the number of cases. Each test case contains four lines

For i-th line of each test case there are two integers  A , B  which means you solved the i-th problem in A minutes and you have made B wrong submissons.

0A105 0B100
 

Output
For each case, the output should occupies exactly one line. The output format is Case #x: ans, here x is the data number begins at 1.
 

Sample Input
  
  
2 4 0 12 0 20 0 103 0 17 1 29 0 57 0 84 0
 

Sample Output
  
  
Case #1: 5722 Case #2: 5412
 

Source
 


解题:套下公式即可,注意分数不能低于40%。


代码:

#include <iostream>
#include <cmath> 
#define e  2.718281828459
using namespace std;
int max(double a,int b)
{
	if(a>b)return (int)a;
	else return b;
}
int main()
{
	int t,total,timee,wrong;
	cin>>t;
	for(int i=1;i<=t;i++)
	{
		total=0;
		for(int j=1000;j<=2500;j+=500)
		{
			cin>>timee>>wrong;
			total+=max((250.0-timee)/250*j-wrong*50,j*2/5);
		}
		cout<<"Case #"<<i<<": "<<total<<endl;
	}
   return 0; 
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值