HDU 5023 A Corrupt Mayor's Performance Art (线段树区间更新,入门详解)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5023


题面:

A Corrupt Mayor's Performance Art

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 100000/100000 K (Java/Others)
Total Submission(s): 1787    Accepted Submission(s): 620


Problem Description
Corrupt governors always find ways to get dirty money. Paint something, then sell the worthless painting at a high price to someone who wants to bribe him/her on an auction, this seemed a safe way for mayor X to make money.

Because a lot of people praised mayor X's painting(of course, X was a mayor), mayor X believed more and more that he was a very talented painter. Soon mayor X was not satisfied with only making money. He wanted to be a famous painter. So he joined the local painting associates. Other painters had to elect him as the chairman of the associates. Then his painting sold at better price.

The local middle school from which mayor X graduated, wanted to beat mayor X's horse fart(In Chinese English, beating one's horse fart means flattering one hard). They built a wall, and invited mayor X to paint on it. Mayor X was very happy. But he really had no idea about what to paint because he could only paint very abstract paintings which nobody really understand. Mayor X's secretary suggested that he could make this thing not only a painting, but also a performance art work.

This was the secretary's idea:

The wall was divided into N segments and the width of each segment was one cun(cun is a Chinese length unit). All segments were numbered from 1 to N, from left to right. There were 30 kinds of colors mayor X could use to paint the wall. They named those colors as color 1, color 2 .... color 30. The wall's original color was color 2. Every time mayor X would paint some consecutive segments with a certain kind of color, and he did this for many times. Trying to make his performance art fancy, mayor X declared that at any moment, if someone asked how many kind of colors were there on any consecutive segments, he could give the number immediately without counting.

But mayor X didn't know how to give the right answer. Your friend, Mr. W was an secret officer of anti-corruption bureau, he helped mayor X on this problem and gained his trust. Do you know how Mr. Q did this?
 

Input
There are several test cases.

For each test case:

The first line contains two integers, N and M ,meaning that the wall is divided into N segments and there are M operations(0 < N <= 1,000,000; 0<M<=100,000) 

Then M lines follow, each representing an operation. There are two kinds of operations, as described below: 

1) P a b c 
a, b and c are integers. This operation means that mayor X painted all segments from segment a to segment b with color c ( 0 < a<=b <= N, 0 < c <= 30).

2) Q a b
a and b are integers. This is a query operation. It means that someone asked that how many kinds of colors were there from segment a to segment b ( 0 < a<=b <= N).

Please note that the operations are given in time sequence.

The input ends with M = 0 and N = 0.
 

Output
For each query operation, print all kinds of color on the queried segments. For color 1, print 1, for color 2, print 2 ... etc. And this color sequence must be in ascending order.
 

Sample Input
  
  
5 10 P 1 2 3 P 2 3 4 Q 2 3 Q 1 3 P 3 5 4 P 1 2 7 Q 1 3 Q 3 4 P 5 5 8 Q 1 5 0 0
 

Sample Output
  
  
4 3 4 4 7 4 4 7 8
 

Source
 

题目大意:

    两种操作,一、将某段区间内涂成某种颜色。二、查询某段区间内颜色种类数。颜色数最多为30种。


解题:

    明显的线段树区间更新,比较难的是颜色的更新和表示。因为只有30种,可以用二进制压缩,某位表示某种颜色有或没有。向下更新时,只需将父节点状态值赋值给子节点。向上更新时,将两子节点的状态值按位或得到父节点的状态值。


代码:

#include <iostream>
#include <cstdio>
//左右儿子 
#define ls i<<1
#define rs (i<<1)|1
#define siz 1000010
using namespace std;
//左右边界,颜色状态值,懒标记 
struct STree
{
    int l,r,color,lazy;
}store[siz<<2];
//向上更新,左右节点的按位或 
void push_up(int i)
{
    store[i].color=store[ls].color|store[rs].color;
}
//建树,i当前节点序号,l,r左右边界 
void build_tree(int i,int l,int r)
{
    store[i].l=l;
    store[i].r=r;
    store[i].lazy=0;
    //叶子节点,停止递归 
    if(l==r)
    {
    	//原色为2 
        store[i].color=2;
        store[i].lazy=0;
        return;
    }
    //向下分两半递归 
    int mid=(l+r)>>1;
    build_tree(ls,l,mid);
    build_tree(rs,mid+1,r);
    //向上更新 
    push_up(i);
}
//下放懒标记 
void push_down(int i)
{
	//下放懒标记 
    store[ls].lazy=store[i].lazy;
    store[rs].lazy=store[i].lazy;
    //父节点懒标记清零 
    store[i].lazy=0;
    //颜色覆盖 
    store[ls].color=store[i].color;
    store[rs].color=store[i].color;
}
//更新函数 
void update(int i,int l,int r,int clo)
{
	//完全覆盖 
    if(store[i].l==l&&store[i].r==r)
    {
        store[i].color=clo;
        store[i].lazy=clo;
        return;
    }
    //下放懒标记 
    if(store[i].lazy)
      push_down(i);
    int mid=(store[i].l+store[i].r)>>1;
    //向下更新 
    if(r<=mid)
      update(ls,l,r,clo);
    else if(l>mid)
      update(rs,l,r,clo);
    else
    {
      update(ls,l,mid,clo);
      update(rs,mid+1,r,clo);
    }
    push_up(i);
}
//查询函数 
int query(int i,int l,int r)
{
    if(l==store[i].l&&r==store[i].r)
      return store[i].color;
    if(store[i].lazy)
      push_down(i);
    int mid=(store[i].l+store[i].r)>>1;
    //按边界情况查询 
    if(r<=mid)
      return query(ls,l,r);
    else if(l>mid)
      return query(rs,l,r);
    else
      return query(ls,l,mid)|query(rs,mid+1,r);
}
int main()
{
	//res保存答案 
    int n,m,fm,to,clo,ans,cnt,res[30];
    char oper;
    while(scanf("%d%d",&n,&m))
    {
       if(n==0&&m==0)break;
       //建树 
       build_tree(1,1,n);
       for(int i=1;i<=m;i++)
       {
          scanf(" %c",&oper);
          //更新操作 
          if(oper=='P')
          {
             scanf("%d%d%d",&fm,&to,&clo);
             update(1,fm,to,(1<<(clo-1)));
          }
          //查询函数 
          else
          {
            scanf("%d%d",&fm,&to);
            ans=query(1,fm,to);
            cnt=0;
            for(int j=0;j<30;j++)
            {
                if(ans&(1<<j))
                  res[cnt++]=j+1;
            }
            //输出 
            printf("%d",res[0]);
            for(int j=1;j<cnt;j++)
              printf(" %d",res[j]);
            printf("\n");
          }
       }
    }
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值