HDU 2602 Bone Collector (01背包)

题目链接:HDU 2602


题面:

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 51402    Accepted Submission(s): 21624


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
  
  
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
14
 

Author
Teddy
 

Source


题意:

   给定n个物品的体积和价值,问背包容量为v的包,能装的最大价值为多少?

 

解题:

    裸的背包,压缩两维为1维,推导容量从大到小进行,(因为大的容量会用到小的容量的dp值)。


代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#define LL long long
#define mod 1000000007
#define sz 100005
using namespace std;
int dp[1005];
int w[1005],val[1005];
int main()
{
    int t,n,v,ans=0;
	scanf("%d",&t);
	while(t--)
	{
       scanf("%d%d",&n,&v);
	   memset(dp,0,sizeof(dp));
	   for(int i=1;i<=n;i++)
		   scanf("%d",&val[i]);
	   for(int i=1;i<=n;i++)
		   scanf("%d",&w[i]);
	   for(int i=1;i<=n;i++)
		   for(int j=v;j>=w[i];j--)
			   dp[j]=max(dp[j],dp[j-w[i]]+val[i]);
	   ans=0;
	   for(int i=0;i<=v;i++)
		   if(dp[i]>ans)
			   ans=dp[i];
	   printf("%d\n",ans);
	}
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值