POJ 2155 Matrix (二维线段树)

题目链接:https://cn.vjudge.net/problem/POJ-2155

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

区间更新,单点查询,计算当前点被覆盖多少次,如果是偶数那么覆盖被抵消输出0,否则输出1

 

 

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

const int maxn = 1e3 + 10;
struct nodey {
    int l, r;
    int val;
};
int lox[maxn], loy[maxn], n, q, T;
struct nodex{
    int l, r;
    nodey sty[maxn * 3];
    void build(int L, int R, int cur){
        sty[cur].l = L;
        sty[cur].r = R;
        sty[cur].val = 0;
        if(L == R) {
            loy[L] = cur;
            return ;
        }
        int mid = L + R >> 1;
        build(L, mid, cur << 1);
        build(mid + 1, R, cur << 1 | 1);
    }
    void update(int L, int R, int cur, int val) {
        if(L <= sty[cur].l && sty[cur].r <= R){
            sty[cur].val += val;
            return;
        }
        int mid = sty[cur].l + sty[cur].r >> 1;
        if(L <= mid) update(L, R, cur << 1, val);
        if(R > mid) update(L, R, cur << 1 | 1, val);
        //sty[cur].val = sty[cur << 1].val + sty[cur << 1 | 1].val;
    }
}stx[maxn * 3];

void build(int L, int R, int cur){
    stx[cur].l = L;
    stx[cur].r = R;
    stx[cur].build(1,n,1);
    if(L == R) {
        lox[L] = cur;
        return ;
    }
    int mid = L + R >> 1;
    build(L, mid, cur << 1);
    build(mid + 1, R, cur << 1 | 1);
}

void update(int x1, int x2, int y1, int y2, int cur, int val) {
    if(x1 <= stx[cur].l && stx[cur].r <= x2){
        stx[cur].update(y1, y2, 1, val);
        return;
    }
    int mid = stx[cur].l + stx[cur].r >> 1;
    if(x1 <= mid) update(x1, x2, y1, y2, cur << 1, val);
    if(x2 > mid) update(x1, x2, y1, y2, cur << 1 | 1, val);
}

int query(int x, int y){
    int ans = 0;
    for(int i = lox[x]; i; i >>= 1){
        for(int j = loy[y]; j; j >>= 1){
            ans += stx[i].sty[j].val;
        }
    }
    return ans;
}

int main() {

    scanf("%d", &T);
    while(T--) {
        scanf("%d%d", &n, &q);
        build(1, n, 1);
        while(q--) {
            char op[2];
            int x1, x2, y1, y2;
            scanf("%s",op);
            if(op[0] == 'C') {
                scanf("%d%d%d%d", &x1, &y1, &x2, &y2);
                update(x1, x2, y1, y2, 1, 1);
            }
            else{
                scanf("%d%d", &x1, &y1);
                int ans = query(x1, y1);
                if(ans & 1) puts("1");
                else puts("0");
            }
        }
        if(T)printf("\n");
    }

    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值