1110 Complete Binary Tree (25分)

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:


```cpp
YES 8

# Sample Input 2:

```cpp
8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1

题⽬⼤意:

给出⼀个n表示有n个结点,这n个结点为0~n-1,给出这n个结点的左右孩⼦,求问这棵树是不是完全⼆叉树

分析:

递归出最⼤的下标值,完全⼆叉树⼀定把前⾯的下标充满: 最⼤的下标值 == 最⼤的节点数;不完全⼆叉树前满⼀定有位置是空,会往后挤: 最⼤的下标值 > 最⼤的节点数

#include <iostream>
using namespace std;
struct Node
{
	int lchild,rchild;
} node[30];
bool hashTable[30];
int maxIndex=-1,ans;
void preOrder(int root,int index)
{
	if(root==-1)
		return ;
	if(index>maxIndex)
	{
		maxIndex=index;
		ans=root;
	}
	preOrder(node[root].lchild,index*2);
	preOrder(node[root].rchild,index*2+1);
}
int main()
{
	int n;
	cin>>n;
	//getchar();
	for(int i=0; i<n; i++)
	{
//		string str;
//		getline(cin,str);
//		if(str[0]!='-')
//		{
//			hashTable[str[0]-'0']=true;
//			node[i].lchild=str[0]-'0';//这种输入只对10以内的节点有效,有3个测试样例不通过 
//		}
//		else
//			node[i].lchild=-1;
//		if(str[2]!='-')
//		{
//			hashTable[str[2]-'0']=true;
//			node[i].rchild=str[2]-'0';
//		}
//		else
//			node[i].rchild=-1;

		string l, r;
		cin >> l >> r;
		if (l == "-")
		{
			node[i].lchild = -1;
		}
		else
		{
			node[i].lchild = stoi(l);
			hashTable[stoi(l)] = true;
		}
		if (r == "-")
		{
			node[i].rchild = -1;
		}
		else
		{
			node[i].rchild = stoi(r);
			hashTable[stoi(r)] = true;
		}
	}
	int root=0;
	while(hashTable[root]!=false)
	{
		root++;
	}
	preOrder(root,1);
	if(maxIndex==n)
		cout<<"YES "<<ans;
	else
		cout<<"NO "<<root;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值