W - Blocks(POJ3734 矩阵快速幂)

W - Blocks

Panda has received an assignment of painting a line of blocks. Since Panda is such an intelligent boy, he starts to think of a math problem of painting. Suppose there are N blocks in a line and each block can be paint red, blue, green or yellow. For some myterious reasons, Panda want both the number of red blocks and green blocks to be even numbers. Under such conditions, Panda wants to know the number of different ways to paint these blocks.

Input

The first line of the input contains an integer T(1≤T≤100), the number of test cases. Each of the next T lines contains an integer N(1≤N≤10^9) indicating the number of blocks.

Output

For each test cases, output the number of ways to paint the blocks in a single line. Since the answer may be quite large, you have to module it by 10007.

Sample Input

2
1
2

Sample Output

2
6

题意:

有n个盒子排成一列,现在要你给盒子染色,有红,蓝,绿,黄四种颜色,其中红色和绿色染色的必须为偶数个,其余随意,问你有几种方法。

分析:

令a(n)为n个盒子,其中红色和绿色为分别为偶数个的方法

令b(n)为n个盒子,其中红色为奇数和,绿色为偶数个的方法

令c(n)为n个盒子,其中红色和绿色都为奇数个的方法

所以有下列方程成立

a ( n ) = 2 ∗ a ( n − 1 ) + 2 ∗ b ( n − 1 ) a(n)=2*a(n-1)+2*b(n-1) a(n)=2a(n1)+2b(n1)

b ( n ) = a ( n − 1 ) + 2 ∗ b ( n − 1 ) + c ( n − 1 ) b(n)=a(n-1)+2*b(n-1)+c(n-1) b(n)=a(n1)+2b(n1)+c(n1)

c ( n ) = 2 ∗ b ( n − 1 ) + 2 ∗ c ( n − 1 ) c(n)=2*b(n-1)+2*c(n-1) c(n)=2b(n1)+2c(n1)

为了加速该递推式,构建矩阵快速幂即可
[ a ( n ) b ( n ) c ( n ) ] = [ 2 2 0 1 2 1 0 2 2 ] ∗ [ a ( n − 1 ) b ( n − 1 ) c ( n − 1 ) ] \left[ \begin{matrix} a(n)\\ b(n)\\ c(n) \\ \end{matrix} \right]= \left[ \begin{matrix} 2&2&0\\ 1&2&1\\ 0&2&2 \\ \end{matrix} \right] * \left[ \begin{matrix} a(n-1)\\ b(n-1)\\ c(n-1) \\ \end{matrix} \right] a(n)b(n)c(n)=210222012a(n1)b(n1)c(n1)

#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<iostream>
#include<iomanip>
#include<stack>
#include<vector>
#define mset(a,b)   memset(a,b,sizeof(a))
using namespace std;
typedef unsigned long long ull;
typedef long long ll;
const int maxn=3;
const int branch=26;
const int inf=0x3f3f3f3f;
const int MOD=10007;
struct Matrix
{
    int m[maxn][maxn];
    Matrix operator = (const Matrix& b)
    {
        for(int i=0; i<maxn; ++i)
            for(int j=0; j<maxn; ++j)
                m[i][j]=b.m[i][j];
        return *this;
    }
    void Print() const
    {
        for(int i=0; i<maxn; ++i)
        {
            for(int j=0; j<maxn; ++j)
            {
                printf("%d ",m[i][j]);
            }
            printf("\n");
        }
        printf("\n");
    }
};
Matrix operator *(const Matrix& a,const Matrix& b)
{
    Matrix ans;
//    a.Print();
//    b.Print();
        for(int i=0; i<maxn; ++i)
            for(int j=0; j<maxn; ++j)
            {
                ans.m[i][j]=0;
                for(int k=0; k<maxn; ++k)
                    ans.m[i][j]=(ans.m[i][j]+a.m[i][k]*b.m[k][j])%MOD;
            }
//    ans.Print();
    return ans;
}
Matrix quick_pow(Matrix a,int b)
{
    Matrix ans;
    mset(ans.m,0);
    for(int i=0; i<maxn; ++i)
        ans.m[i][i]=1;
    while(b)
    {
        if(b&1)
            ans=ans*a;
        b/=2;
        a=a*a;
    }
    return ans;
}
int solve(int n)
{
    Matrix ans;
    ans.m[0][0]=2,ans.m[0][1]=2,ans.m[0][2]=0;
    ans.m[1][0]=1,ans.m[1][1]=2,ans.m[1][2]=1;
    ans.m[2][0]=0,ans.m[2][1]=2,ans.m[2][2]=2;
    ans=quick_pow(ans,n-1);
    return (ans.m[0][0]*2+ans.m[0][1])%MOD;
}
int main()
{
    int n,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        printf("%d\n",solve(n));
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值