hdoj 2602 Bone Collector

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 73997    Accepted Submission(s): 30766


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
 
 
15 101 2 3 4 55 4 3 2 1
 

Sample Output
 
 
14
 

Author
Teddy

01背包的特点是:每种物品都只有一件且不能分裂,所以对应的只有选与不选两种可能

用一个数组dp表示当装物品体积为j时背包的总价值,状态转移方程为dp[j]=max(dp[j],dp[j-i物品的体积]+i物品的价值),其中,dp[j]表示不把第i个物品放入背包中,dp[j-i物品的体积]+i物品的价值 表示将第i个物品放入背包中,如此,从第1个物品开始遍历,一直到第n个物品,然后解决放与不放的问题,只需要将体积从V遍历到第i个物品的体积即可,因为如果体积小于物品体积的话,该物品就放不下了

/*01背包就是选与不选的问题*/ 
#include<stdio.h>
#include<string.h> 
#include<math.h>
#include<algorithm>
using namespace std;
int main(){
	int T,N,V;
	scanf("%d",&T);
	while(T--){
		int vol[1005],val[1005],dp[1005];
		memset(dp,0,sizeof(dp));
		scanf("%d %d",&N,&V);
		for(int i=0;i<N;i++){
			scanf("%d",&val[i]);
		}
		for(int i=0;i<N;i++){
			scanf("%d",&vol[i]);
		}
		for(int i=0;i<N;i++){
			for(int j=V;j>=vol[i];j--){
				dp[j]=max(dp[j],dp[j-vol[i]]+val[i]);
				//dp[j]表示不选择第i个,dp[j-vol[i]]+val[i]表示选择第i个 不放第i个物品则表示体积依然是j,
				可以不做处理,但是如果放进去第i个物品,则需要寻找上移状态背包的最大价值)
			}
		}
		printf("%d\n",dp[V]);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值