nyoj 43 24 Point game

24 Point game

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 5
描述

There is a game which is called 24 Point game.

In this game , you will be given some numbers. Your task is to find an expression which have all the given numbers and the value of the expression should be 24 .The expression mustn't have any other operator except plus,minus,multiply,divide and the brackets. 

e.g. If the numbers you are given is "3 3 8 8", you can give "8/(3-8/3)" as an answer. All the numbers should be used and the bracktes can be nested. 

Your task in this problem is only to judge whether the given numbers can be used to find a expression whose value is the given number。

输入
The input has multicases and each case contains one line
The first line of the input is an non-negative integer C(C<=100),which indicates the number of the cases.
Each line has some integers,the first integer M(0<=M<=5) is the total number of the given numbers to consist the expression,the second integers N(0<=N<=100) is the number which the value of the expression should be.
Then,the followed M integer is the given numbers. All the given numbers is non-negative and less than 100
输出
For each test-cases,output "Yes" if there is an expression which fit all the demands,otherwise output "No" instead.
样例输入
2
4 24 3 3 8 8
3 24 8 3 3
样例输出
Yes
No
来源
经典改编
上传者

张云聪

#深搜#深搜主要是参数的选择,参数选好了也就好理解了,当然,深搜的过程也是比较难把握的,这里搜索是任意两个数通过加减乘除组合成一个新数,然后这个新数再通过加减乘除跟剩下的没有用过的数进行加减乘除运算,这样一步一步搜索,直到数字已经用完为止,如果还没有答案,那就是false了

#include<stdio.h>
#include<math.h>
#include<string.h>
int M;
double N;
double a[6];//记录数字
int visit[6];//记录当前搜索方案中此数字是否被用过
int flag=0;//全局变量 
void dfs(double sum,int use){//sum表示当前和,use表示已经用给的数字个数
	//if(sum==8||sum==3)
	//printf("%.2f\n",sum);
	if(use==M){
		if(fabs(sum-N)<=1e-6){
			flag=1;
			return ;
		}
	}
	for(int i=0;i<M;i++){
		if(!visit[i]){
			visit[i]=1;
			use++;
			dfs(sum+a[i],use);
			dfs(sum-a[i],use);
			dfs(sum*a[i],use);
			dfs(a[i]-sum,use);
			if(a[i]){
				dfs(sum/a[i],use);
			}
			if(sum){
				dfs(a[i]/sum,use);
			}
			visit[i]=0;
			use--;
		} 
	}
	return ;
}
int main(){
	int C;
	scanf("%d",&C);
	while(C--){
		memset(a,0,sizeof(a));
		flag=0;
		scanf("%d %lf",&M,&N);
		for(int i=0;i<M;i++){
			scanf("%lf",&a[i]);
		}
		for(int i=0;i<M;i++){
			if(flag)//表示已经找到结果 
			break;
			else{
				memset(visit,0,sizeof(visit));
				visit[i]=1;
				dfs(a[i],1);
			}
		}
		//dfs(0,0);
		if(flag==1)
		printf("Yes\n");
		else
		printf("No\n");
	}
	return 0;
} 
写完题解突然想到,深搜一般可以搜索所有情况,所以如果只要一种情况的话,可以直接用一个全局变量来标记是否已经找到结果,广搜的话也可以搜索所有情况,但是一般题大概就是需要一个状态吧

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值