01-复杂度2 Maximum Subsequence Sum (25分)

01-复杂度2 Maximum Subsequence Sum (25分)

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

基于上一篇的在线处理法,题目加入了一些限定的条件,但都是比较好处理的。

AC代码:

#include<iostream>
using namespace std;
int a[10005];

int main()
{
	int n;int i;
	cin>>n;
	for(i=0;i<n;i++) cin>>a[i];
	int ThisSum=0,MaxSum=-1;     //考虑到最后存在负数和零混合的情况,MaxSum初始化为-1 
	int Maxl,Maxr=0;
	int Thisl=a[0];
	int flag=0;   //判断是否全为负数的标志 
	for(i=0;i<n;++i)
	{
		ThisSum+=a[i];
		if(ThisSum<0)
		{
			ThisSum=0;
			Thisl=a[i+1];
		}
		else if(ThisSum>MaxSum) 
		{
			MaxSum=ThisSum;
			Maxr=a[i];
			Maxl=Thisl;
			flag=1;
		}
	}
	if(flag==1)
		cout<<MaxSum<<" "<<Maxl<<" "<<Maxr;
	else
		cout<<"0 "<<a[0]<<" "<<a[n-1];
	return 0;
}

 在遍历的过程中,实时更新MaxSum和对应的Maxl,Maxr。

代码思路比较清晰这里不做过多说明。

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值