不同软件版本及系统的差异导致的错误汇总

       由于好多软件在不断更新,教程也难免出现错误。我这种半路出家的对照网络教程总是出错,出个错误要找半天。就在这里总结纪录一下我出现的问题以及解决方法。暂且先纪录在这。欢迎大牛指正。
      
       1.java的jdk一定要配置成最新版本。(如果有的程序对java版本有要求,那就删掉这破软件吧。 )
       2.MYSQL的配置要注意自己电脑的host,可能会和通常情况的不一样。(我就找了半天原因找不到。)
       3.hadoop的不同版本的配置文件位置不同,要自己找。启动文件可能不在bin,在sbin。
       4.vim的配置要注意改三个地方的vimrc,可能在不同位置,少一个就不行。
       5.如果不配置vim,PyCharm是mac上比较不错的idle。

       6.python3.的urllib2库如果报错,则用urllib.request调用。

       7.iOS以上使用地图调用需要在info.plist中添加 Privacy - Location Usage Description(可能需要) 以及 NSLocationAlwaysUsageDescription

阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/DeryLiu/article/details/49908281
下一篇Mac下ssh配置相关
想对作者说点什么? 我来说一句

sparkweb中文修正

2010年01月21日 1.47MB 下载

没有更多推荐了,返回首页

关闭
关闭