TZOJ1471: Wall

 1471: Wall 

时间限制(普通/Java):1000MS/10000MS     内存限制:65536KByte
总提交: 162            测试通过:98

描述

Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King's castle. The King was so greedy, that he would not listen to his Architect's proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall.


Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements.

The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle's vertices in feet.

输入

The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King's castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle.

Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.

输出

Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King's requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.

样例输入

样例输出

提示

结果四舍五入就可以了

不知道为什么出c++17过不了,但是c++可以过,还没找到原因

参考了二维凸包公式模版

用叉乘和周长做,在转交处,弧形最短,所以加上L为半径的圆的长度

//ans=凸包周长+半径为 L 的圆的周长

 

AC代码

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int N=1e3+10,INF=0x3f3f3f3f;
int n,res,m,t,l;
double pi=3.14159265357;
double sum;
typedef struct node{
    double x,y;
}node;
node f[N],s[N];
bool cmp(node a,node b){
    if(a.x==b.x)
        return a.y<b.y;
    return a.x<b.x;
}
//ans=凸包周长+半径为 L 的圆的周长
double dis(node x,node y){//两点距离 
   return sqrt(pow(x.x-y.x,2)+pow(x.y-y.y,2));
}
int check(node a,node b,node c){//ab x ac叉乘 
    double abx=b.x-a.x;
    double aby=b.y-a.y;
    double acx=c.x-a.x;
    double acy=c.y-a.y;
    if(abx*acy-aby*acx>0) return 1;
    return 0;

int main()
{
    while(~scanf("%d%d",&n,&l)){
        for(int i=0;i<n;++i)
            scanf("%lf%lf",&f[i].x,&f[i].y);
        sort(f,f+n,cmp);
        int top=0;
        for(int i=0;i<n;++i){
            while(top>=2&&!check(s[top-2],s[top-1],f[i]))
                top--;
            s[top++]=f[i];
        }
        t=top-1;
        for(int i=n-1;i>=0;--i){
            while(top>=t+2&&!check(s[top-2],s[top-1],f[i]))
                top--;
            s[top++]=f[i];
        }
        top--;//上凸包和下凸包首尾重复
           sum=0;
           s[top]=s[0];
        for(int i=0;i<top;++i)
            sum+=dis(s[i],s[i+1]);
        sum+=2*pi*l;
        printf("%.0f\n",sum);    
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值