SDNU——8题——B - Fractions Again?!

It is easy to see that for every fraction in the form 1
k
(k > 0), we can always find two positive integers
x and y, x ≥ y, such that:
1/k=1/x+1/y
Now our question is: can you write a program that counts how many such pairs of x and y there
are for any given k?
Input
Input contains no more than 100 lines, each giving a value of k (0 < k ≤ 10000).
Output
For each k, output the number of corresponding (x, y) pairs, followed by a sorted list of the values of
x and y, as shown in the sample output.
Sample Input
2
12
Sample Output
2
1/2 = 1/6 + 1/3
1/2 = 1/4 + 1/4
8
1/12 = 1/156 + 1/13
1/12 = 1/84 + 1/14
1/12 = 1/60 + 1/15
1/12 = 1/48 + 1/16
1/12 = 1/36 + 1/18
1/12 = 1/30 + 1/20
1/12 = 1/28 + 1/21
1/12 = 1/24 + 1/24  

#include<cstdio>
#include<iostream>
#include<vector>
using namespace std;
int main()
{
	vector<int> rx;
	vector<int> ry;
	int k,x,y,cnt=0,l=0,i;
	while(cin>>k)
	{
		for(y=k+1;y<=2*k;y++)
		{
			if((k*y)%(y-k)==0&&(k*y)/(y-k)>=y)
			{
				x=(k*y)/(y-k);
				cnt++;
				rx.push_back(x);
				ry.push_back(y);
				l++;
			}

		}
		cout<<cnt<<"\n";
		for(i=0;i<l;i++)
		{
			printf("1/%d = 1/%d + 1/%d\n",k,rx[i],ry[i]);
		}
		cnt=0;
		rx.clear();
		ry.clear();
		l=0;
	}
	
	
	
	
	
	return 0;
}


1.暴力要有度,所以想要暴力x与y就得找到,他们的限制之处,这样暴力才能有个头,才不会超时~

你可以试一试你会求出y的范围是【k,2k】,找到y的范围后,我没能找到x的具体范围,所以我就把所有x的值找出来,1.判断是否能整除2.判断是否满足x>y

2.注意输出的一般格式

3.注意下一次输入时,把数组什么的都清空,防止对下一侧的计算造成误差~~~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值