杭电ACM-1004 Let the Balloon Rise

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 61287    Accepted Submission(s): 22571


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
  
  
5 green red blue red red 3 pink orange pink 0
 

Sample Output
  
  
red pink
 


题意:

找出出现次数最多的颜色

解题思路:

利用HashMap的特性,key值存放颜色,value值存放数量。最终遍历HashMap根据数量找出目标颜色

解题代码:
import java.util.HashMap;
import java.util.Map;
import java.util.Scanner;

public class Main1004 {
	
	public static String getMostPopularColor(Map<String, Integer> colorMap) {
		String color = null;
		int count = 0;
		for (Map.Entry<String, Integer> entry : colorMap.entrySet()) {
			if (entry.getValue() > count) {
				count = entry.getValue();
				color = entry.getKey();
			}
		}
		return color;
	}
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int total = 0;
		while ((total = sc.nextInt()) != 0) {
			sc.nextLine();
			Map<String, Integer> colorMap = new HashMap<String, Integer>();
			while (total > 0) {
				String color = sc.nextLine();
				Integer count = colorMap.get(color);
				if (count == null) {
					colorMap.put(color, 1);
					total--;
					continue;
				}
				colorMap.put(color, count+1);
				total--;
			}
			System.out.println(getMostPopularColor(colorMap));
		}
	}
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值