数据结构实验之栈与队列六:下一较大值(二)
Time Limit: 150 ms Memory Limit: 8000 KiB
Problem Description
对于包含n(1<=n<=100000)个整数的序列,对于序列中的每一元素,在序列中查找其位置之后第一个大于它的值,如果找到,输出所找到的值,否则,输出-1。
Input
输入有多组,第一行输入t(1<=t<=10),表示输入的组数;
以后是 t 组输入:每组先输入n,表示本组序列的元素个数,之后依次输入本组的n个元素。
Output
输出有多组,每组之间输出一个空行(最后一组之后没有);
每组输出按照本序列元素的顺序,依次逐行输出当前元素及其查找结果,两者之间以–>间隔。
Sample Input
2
4 12 20 15 18
5 20 15 25 30 6
Sample Output
12–>20
20–>-1
15–>18
18–>-1
20–>25
15–>25
25–>30
30–>-1
6–>-1
Hint
本题数据量大、限时要求高,须借助栈来完成。
Source
#include <stdio.h>
#include <stdlib.h>
int s[100005]; //分配栈的大小
int main()
{
int i,t,n,a[100005],b[100005],top; //b存a对应的下一个较大值
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(i=1;i<=n;i++)
scanf("%d",&a[i]);
top=0;
b[n]=-1; //最后一个数无下一较大值
s[++top]=a[n]; //a[n]入栈
for(i=n-1;i>=1;i--)
{
if(a[i]<s[top])
{
b[i]=s[top]; //找到a[i]的下一较大值存入b[i]
s[++top]=a[i]; //a[i]入栈
}
else
{
while(a[i]>=s[top]&&top!=0)
top--; //不符合条件出栈
if(top==0)
{
b[i]=-1; //无下一较大值
s[++top]=a[i]; //a[i]入栈
}
else
{
b[i]=s[top];
s[++top]=a[i]; //a[i]入栈
}
}
}
for(i=1;i<=n;i++)
printf("%d-->%d\n",a[i],b[i]);
if(t)
printf("\n");
}
return 0;
}