HDU - 1022 Train Problem I(出栈序列判定)

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can’t leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
这里写图片描述这里写图片描述这里写图片描述
Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
Output
The output contains a string “No.” if you can’t exchange O2 to O1, or you should output a line contains “Yes.”, and then output your way in exchanging the order(you should output “in” for a train getting into the railway, and “out” for a train getting out of the railway). Print a line contains “FINISH” after each test case. More details in the Sample Output.
Sample Input
3 123 321
3 123 312
Sample Output
Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can’t let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output “No.”.
Hint
Hint

思路:
第一次做这道题是认为要严格按题目所给的第一个字符串依次入栈,再按第二个字符串依次出栈,判断是否合法。然后就WA了……
之后想了可能是我还没完全理解题意(我英语渣QAQ),其实这道题和SDUT 3334相似。
题目本意是:给一个初始的入栈序列,其次序即为元素的入栈次序,栈顶元素可以随时出栈,每个元素只能入栈依次。输入一个入栈序列,后面输入出栈序列,请判断这些序列是否为所给入栈序列合法的出栈序列。
照这个思路做就AC了。

代码:

#include <stdio.h>
#include <stdlib.h>

int q[10005];
int main()
{
    int i,n,s,top,c[10005],count; //c记录出栈和入栈操作(‘1’表示入栈,‘2’表示出栈)
    char a[10005],b[10005]; //a存入栈的字符,b存出栈的字符
    while(scanf("%d",&n)!=EOF)
    {
        s=0;
        count=0;
        top=0;
        scanf("%s",a);
        scanf("%s",b);
        for(i=0;i<n;i++)  //将要入栈的字符依次入栈,当栈顶字符和出栈字符匹配立即出栈
        {
            q[top++]=a[i];
            c[count]=1;
            count++;
            while(q[top-1]==b[s]&&top!=0)
            {
                top--;
                s++;
                c[count]=0;
                count++;
            }
        }
        if(top==0)  //栈空说明所有字符都匹配成功
        {
           printf("Yes.\n");
           for(i=0;i<count;i++)
           {
               if(c[i]==1)
                printf("in\n");
               else
                printf("out\n");
           }
           printf("FINISH\n");
        }
        else
        {
            printf("No.\n");
            printf("FINISH\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值