HDU6446

Tree and Permutation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 711    Accepted Submission(s): 248


 

Problem Description

There are N vertices connected by N−1 edges, each edge has its own length.
The set { 1,2,3,…,N } contains a total of N! unique permutations, let’s say the i-th permutation is Pi and Pi,j is its j-th number.
For the i-th permutation, it can be a traverse sequence of the tree with N vertices, which means we can go from the Pi,1-th vertex to the Pi,2-th vertex by the shortest path, then go to the Pi,3-th vertex ( also by the shortest path ) , and so on. Finally we’ll reach the Pi,N-th vertex, let’s define the total distance of this route as D(Pi) , so please calculate the sum of D(Pi) for all N! permutations.

 

 

Input

There are 10 test cases at most.
The first line of each test case contains one integer N ( 1≤N≤105 ) .
For the next N−1 lines, each line contains three integer X, Y and L, which means there is an edge between X-th vertex and Y-th of length L ( 1≤X,Y≤N,1≤L≤109 ) .

 

 

Output

For each test case, print the answer module 109+7 in one line.

 

 

Sample Input

 

3 1 2 1 2 3 1 3 1 2 1 1 3 2

 

 

Sample Output

 

16 24

 

 

Source

2018中国大学生程序设计竞赛 - 网络选拔赛

 


#include <bits/stdc++.h>
using namespace std;

struct Edge {
	int to;
	int w;
	Edge(){}
	Edge(int to,int w):to(to),w(w){}
};
vector<Edge> ve[100005];
void addedge(int u, int v, int w) {
            ve[u].push_back(Edge(v,w));
            ve[v].push_back(Edge(u,w));
}

int n;
const int MOD = 1e9+7;
long long ans,n_1;

int dfs(int u, int pre) {
	int size = 1;
	for (int i = 0; i<ve[u].size(); i++) {
		int v = ve[u][i].to;
		if (v == pre)continue;
		int sz = dfs(v, u);
		long long tmp = (long long)(n-sz)*sz%MOD*2%MOD*n_1%MOD*ve[u][i].w%MOD;
		ans = (ans + tmp)%MOD;
		size += sz;
	}
    ve[u].clear();
	return size;
}

int main() {
	while (scanf("%d", &n) == 1) {
		int u,v,w;
		for (int i = 1; i < n; i++) {
			scanf("%d%d%d", &u,&v,&w);
			addedge(u,v,w);
		}
		ans = 0;
		n_1 = 1;
		for (int i = 1; i <= n-1; i++) n_1 = (n_1)*i%MOD;
		dfs(1, -1);
		printf("%lld\n",ans);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值