Description
Given N numbers, X1, X2, … , XN, let us calculate the difference of every pair of numbers: ∣Xi - Xj∣ (1 ≤ i < j ≤ N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!
Note in this problem, the median is defined as the (m/2)-th smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of m = 6.
Input
The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representing X1, X2, … , XN, ( Xi ≤ 1,000,000,000 3 ≤ N ≤ 1,00,000 )
Output
For each test case, output the median in a separate line.
Sample Input
4
1 3 2 4
3
1 10 2
Sample Output
1
8
思路
果然全部找出两个数之间的差值,时间复杂度为 O(n) 在数据量很大的情况下,肯定会超时。
这时可以用二分查找来找到中间值。
二分的思路为:
题目中 m=C(n,2)
而我们要找的中位数 X 是排好序的第m/2 个数
很容易想到,比X大的数的个数 ans=m/2
所以只要找到符合条件的X就可以咯
在计算ans 的时候也可以用二分,不过下面的代码中没有使用。
代码
#include <cstdio>
#include <algorithm>
using namespace std;
int n, a[100005];
int findmid()
{
int mid,l = 0, r = a[n] - a[0] + 1; //最大值只能是(a[n] - a[0])我们可以再加上一
int m = (n-1)*n/2, ans,h = m/2; //m = c(n,2)
if((n*(n-1)/2)&1) h ++;
while(l <= r)
{
int j;
mid = (l + r) >> 1;
j = 1;
ans = 0;
for(int i = 2; i <= n; i ++)
{
while(a[i] - a[j] > mid)
j ++;
ans += (i-j);
}
if(ans >= h)
r = mid - 1;
else
l = mid + 1;
}
return l;
}
int main()
{
while(~scanf("%d", &n))
{
for(int i = 1; i <= n; i ++)
scanf("%d", a + i);
sort(a + 1, a + n + 1);
printf("%d\n", findmid());
}
return 0;
}